summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lxqt-base/lxqt-sudo/Manifest1
-rw-r--r--lxqt-base/lxqt-sudo/lxqt-sudo-0.13.0.ebuild38
-rw-r--r--lxqt-base/lxqt-sudo/metadata.xml11
3 files changed, 46 insertions, 4 deletions
diff --git a/lxqt-base/lxqt-sudo/Manifest b/lxqt-base/lxqt-sudo/Manifest
index af91cd3490c4..539699d5eb23 100644
--- a/lxqt-base/lxqt-sudo/Manifest
+++ b/lxqt-base/lxqt-sudo/Manifest
@@ -1 +1,2 @@
DIST lxqt-sudo-0.11.0.tar.xz 15960 BLAKE2B 5b4c4f8c748f330508665141d02eb62e1a2804c6510f7fc455c2761527436c8a81c2e3d0ac6484511effe3485d712e10a2741fe1019356480e5824cbb97482f1 SHA512 42f8a74898ed4fa81fcff06837e69e0c7cb4f2fb81b21a0167afd5f0557fab48022de0849c83dcb5e04e2f3f3af54cd0c2c8fc27cde15ad380163a7a9fe1724e
+DIST lxqt-sudo-0.13.0.tar.xz 16208 BLAKE2B 83da7ca7fcd4f670e5569ea9869047eafbac68fd43469a3fba1ba51470f9417fbfa7403f1b854b4270aa9b4779475b7a2a97dcb755e02c189b4d87bd969d4b57 SHA512 ea7d8ca093e736e3cf581605598cb9c8ed4e40bc39fb94a4b44334e7f58ae53c489ede0dcfc75de8daf58c115c1a91ae152f676276488df8a16ed53bbf56fc82
diff --git a/lxqt-base/lxqt-sudo/lxqt-sudo-0.13.0.ebuild b/lxqt-base/lxqt-sudo/lxqt-sudo-0.13.0.ebuild
new file mode 100644
index 000000000000..01f913a3df33
--- /dev/null
+++ b/lxqt-base/lxqt-sudo/lxqt-sudo-0.13.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils eapi7-ver
+
+DESCRIPTION="LXQt GUI frontend for sudo"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+RDEPEND="
+ app-admin/sudo
+ >=dev-libs/libqtxdg-3.0.0
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+"
+DEPEND="${RDEPEND}
+ >=dev-util/lxqt-build-tools-0.5.0
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DPULL_TRANSLATIONS=OFF
+ )
+ cmake-utils_src_configure
+}
diff --git a/lxqt-base/lxqt-sudo/metadata.xml b/lxqt-base/lxqt-sudo/metadata.xml
index 3eaa3d72d65d..34a55e64f955 100644
--- a/lxqt-base/lxqt-sudo/metadata.xml
+++ b/lxqt-base/lxqt-sudo/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>lxqt@gentoo.org</email>
- <name>LXQt</name>
- </maintainer>
+ <maintainer type="project">
+ <email>lxqt@gentoo.org</email>
+ <name>LXQt</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lxqt/lxqt-sudo</remote-id>
+ </upstream>
</pkgmetadata>