summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-util/lutris/Manifest1
-rw-r--r--games-util/lutris/lutris-0.4.14.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/games-util/lutris/Manifest b/games-util/lutris/Manifest
index d390e0b4246f..5745af35c92e 100644
--- a/games-util/lutris/Manifest
+++ b/games-util/lutris/Manifest
@@ -1,3 +1,4 @@
DIST lutris-0.4.13.tar.gz 1028111 BLAKE2B 46abb83a5ed27c5f7d7bb8a6183e4b950c79cc811e6eade996789df4d81fb73d51d202bf3cc9ac46abc30d2a2b8291a001b4df1d0dd4912d7e6c30705fc65912 SHA512 006e4cc237a60bd925cee87046664f766686a15c692f7717e6fd25bee377880bd96f788309966e8e0dabdf2c938e0da0f8914c7e70554f216b8513aa41bc808a
+DIST lutris-0.4.14.tar.gz 1617493 BLAKE2B c97d0e31657252c4ae5c6718151f028d273831cdb9f21b748ada651686cf3aa51a618a007db87528d84f21dca292509399f9bb1f0c0444c57e369b13b9ae79a0 SHA512 d229d7f79b3395db22ad49abc02ca5e08db9465258be33fcefe743c0a099e1ca507b6b9c28f03d2a6857489f7f2e19fca38803f6876df88a96b060ed5f7f94bc
DIST lutris_0.3.6.3.tar.gz 515606 BLAKE2B 5c23c26419b1fa0bb836aa90c5b9bec8fceff544ddefb314c5b4c5c060be278eccbb7f9c21b4a2190e5232d6abfa31e25b141e4a2d72f941385c94db6d6b9871 SHA512 548a3a79ffb1c378d923f404634acc3b5eb1055d087ff212cf8a35b7db56650bf616f3b7374ab9fdf996c8f10d80ab602d35d126ef3bb183b9ce55b36d270e97
DIST lutris_0.3.8.tar.xz 658408 BLAKE2B 2a31206052a87873146609d229fb93b9a991ffb5f92f9d4f5b2a576b41d16815b5122168a5073ea44883d73223aa0fcc6dec46d9b909d594750d06300263f3e4 SHA512 165e9c045e82407dfd6dd35fa73a98b68d095119596b9f0e66867c92071d1178526ddf991fc6b05449446c9d7c1a573ffea564d93d440cebdaa788c61e57fcfe
diff --git a/games-util/lutris/lutris-0.4.14.ebuild b/games-util/lutris/lutris-0.4.14.ebuild
new file mode 100644
index 000000000000..960cafec846a
--- /dev/null
+++ b/games-util/lutris/lutris-0.4.14.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE="sqlite,threads"
+
+inherit distutils-r1 gnome2-utils python-r1
+
+DESCRIPTION="Lutris is an open source gaming platform for GNU/Linux."
+HOMEPAGE="https://lutris.net/"
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/lutris/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/lutris/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ net-libs/libsoup
+ x11-apps/xrandr
+ x11-apps/xgamma"
+
+python_install() {
+ distutils-r1_python_install
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ # README.rst contains list of optional deps
+ DOCS=( AUTHORS README.rst INSTALL.rst )
+ distutils-r1_src_install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+
+ elog "For a list of optional dependencies (runners) see:"
+ elog "/usr/share/doc/${PF}/README.rst.bz2"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}