summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/scotch/scotch-6.0.4-r2.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sci-libs/scotch/scotch-6.0.4-r2.ebuild b/sci-libs/scotch/scotch-6.0.4-r2.ebuild
index 8af0ccfe611a..4a01b91e5ca2 100644
--- a/sci-libs/scotch/scotch-6.0.4-r2.ebuild
+++ b/sci-libs/scotch/scotch-6.0.4-r2.ebuild
@@ -64,10 +64,12 @@ src_prepare() {
-e 's/ -DSCOTCH_PTHREAD//' \
src/Make.inc/Makefile.inc.i686_pc_linux3 || die
fi
- sed -e "s/gcc/$(tc-getCC)/" \
+
+ # Be careful with replacing here, bug #577272
+ sed -e "s/= gcc$/= $(tc-getCC)/" \
-e "s/-O3/${CFLAGS} -pthread/" \
- -e "s/ ar/ $(tc-getAR)/" \
- -e "s/ranlib/$(tc-getRANLIB)/" \
+ -e "s/= ar$/= $(tc-getAR)/" \
+ -e "s/= ranlib$/= $(tc-getRANLIB)/" \
-e "s/LDFLAGS/LIBS/" \
src/Make.inc/Makefile.inc.i686_pc_linux3 > src/Makefile.inc || die
}