summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-strategy/attal/Manifest2
-rw-r--r--games-strategy/attal/attal-0.10.1.ebuild62
-rw-r--r--games-strategy/attal/files/attal-0.10.1-gcc41.patch33
-rw-r--r--games-strategy/attal/files/attal-0.10.1-gentoo.patch33
-rw-r--r--games-strategy/attal/metadata.xml11
5 files changed, 0 insertions, 141 deletions
diff --git a/games-strategy/attal/Manifest b/games-strategy/attal/Manifest
deleted file mode 100644
index f516969c9cba..000000000000
--- a/games-strategy/attal/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST attal-src-0.10.1.tar.bz2 283704 SHA256 9dd692daa99dbf3ec14c178b5b3334a6a4085f790749aa58cf45ddf8c5e8649b SHA512 352b044aafd5e25ebdfa2c42af3c58c91a173db39461b2c845aaee964e418976cd58afa9f92fd99e3e498f7fad005c133d1482d212250477fc20b328e2e926db WHIRLPOOL 9a6865837f7fc8ec03e2441cfde8dba3e61cef3b12d231625e545ec0e01b4e2979311d6a5a7de19354edd07dd44db3ae8f0e5bbb05d561ff645d4c921316442a
-DIST themes-0.10.1.tar.bz2 30744206 SHA256 1f0e9c8b70ac8fd50cf7af492177b88383b230fe400f6ffa4b5641badac5a002 SHA512 cf3362f2ca5772135ab4e1760ac42ebc8195e6285c2cb96e8b89553851953c6fe15c5c06b30a4bd4e413c212b0f81d0386fedfddb089463824dfccefc3cc252a WHIRLPOOL ba0a3e1ba3805923a491fe64e4a175c27fe377fb2cbdca24f23b84c673fe010b044f3fef63ec864ef5ecda159035e3e1d8cca12ebf1ad01b3fd3b1af3b70d9ea
diff --git a/games-strategy/attal/attal-0.10.1.ebuild b/games-strategy/attal/attal-0.10.1.ebuild
deleted file mode 100644
index f3c320648fac..000000000000
--- a/games-strategy/attal/attal-0.10.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=2
-inherit eutils qt4-r2 games
-
-MY_P="${PN}-src-${PV}"
-DESCRIPTION="turn-based strategy game project"
-HOMEPAGE="http://www.attal-thegame.org/"
-SRC_URI="mirror://sourceforge/attal/${MY_P}.tar.bz2
- mirror://sourceforge/attal/themes-${PV}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ppc x86"
-IUSE=""
-
-DEPEND="dev-qt/qtgui:4
- dev-qt/qtsql:4
- dev-qt/qt3support:4
- media-libs/libsdl
- media-libs/sdl-mixer[vorbis]"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- mv ../themes .
- ecvs_clean
- epatch \
- "${FILESDIR}"/${P}-gcc41.patch \
- "${FILESDIR}"/${P}-gentoo.patch
- sed -i \
- -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
- libCommon/displayHelp.cpp \
- libCommon/attalCommon.cpp \
- server/duel.cpp \
- || die "sed failed"
-}
-
-src_configure() {
- eqmake4 Makefile.pro
-}
-
-src_compile() {
- local d
-
- for d in Common Client Fight Server
- do
- emake sub-lib$d || die "emake failed"
- done
- emake || die "emake failed"
-}
-
-src_install() {
- dogamesbin attal-* || die "dogamesbin failed"
- dogameslib.so lib*.so* || die "dogameslib.so failed"
- insinto "${GAMES_DATADIR}"/${PN}
- doins -r themes HOWTOPLAY.html || die "doins failed"
- dodoc AUTHORS NEWS README TODO
- prepgamesdirs
-}
diff --git a/games-strategy/attal/files/attal-0.10.1-gcc41.patch b/games-strategy/attal/files/attal-0.10.1-gcc41.patch
deleted file mode 100644
index 161aa3251d2e..000000000000
--- a/games-strategy/attal/files/attal-0.10.1-gcc41.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- libClient/ressourceWin.h.old 2006-09-11 20:57:10.000000000 +0200
-+++ libClient/ressourceWin.h 2006-09-11 20:57:24.000000000 +0200
-@@ -54,7 +54,7 @@
-
- public:
- /** Construtcor */
-- RessourceWin( QWidget * parent = 0, const char * name = 0, WinResType type );
-+ RessourceWin( QWidget * parent, const char * name, WinResType type );
-
- /** Initialize player */
- void setPlayer( GenericPlayer * );
---- libCommon/creature.h.old 2006-05-25 00:50:11.000000000 -0400
-+++ libCommon/creature.h 2006-05-25 00:51:51.000000000 -0400
-@@ -38,6 +38,7 @@
-
- class CreatureHandler;
- class GenericFightUnit;
-+int computeSequence( GenericFightUnit * unit );
-
- /** Manage a creature */
- enum CreatureAnimationType {
-
---- server/serverInterface.h.old 2006-09-11 21:33:00.000000000 +0200
-+++ server/serverInterface.h 2006-09-11 21:33:16.000000000 +0200
-@@ -135,7 +135,7 @@
- void initStatusBar();
-
- /** Add new action */
-- QAction * ServerInterface::addAction( const QString & label, MENU_ACTIONS id, QSignalMapper * sigmap );
-+ QAction *addAction( const QString & label, MENU_ACTIONS id, QSignalMapper * sigmap );
-
- void addAI(bool hide);
-
diff --git a/games-strategy/attal/files/attal-0.10.1-gentoo.patch b/games-strategy/attal/files/attal-0.10.1-gentoo.patch
deleted file mode 100644
index ab8d0c605105..000000000000
--- a/games-strategy/attal/files/attal-0.10.1-gentoo.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- libCommon/displayHelp.cpp.old 2006-09-11 22:41:38.000000000 +0200
-+++ libCommon/displayHelp.cpp 2006-09-11 22:42:20.000000000 +0200
-@@ -44,7 +44,7 @@
- _text->mimeSourceFactory()->setFilePath( QString(".") );
- _text->mimeSourceFactory()->setExtensionType( "html", "text/html;charset=iso8859-1" );
- _text->setTextFormat( Qt::RichText );
-- _text->setSource( "./HOWTOPLAY.html" );
-+ _text->setSource( "@GENTOO_DATADIR@/HOWTOPLAY.html" );
-
- QPushButton * pbOk = new QPushButton( this );
- pbOk->setText( QObject::tr( "Ok" ) );
---- libCommon/attalCommon.cpp.old 2006-09-11 22:45:23.000000000 +0200
-+++ libCommon/attalCommon.cpp 2006-09-11 22:47:28.000000000 +0200
-@@ -52,7 +52,7 @@
- {
- QDir folder;
-
-- folder.setPath( "./themes/" + THEME );
-+ folder.setPath( "@GENTOO_DATADIR@/themes/" + THEME );
-
- #ifndef WIN32
- if( ! folder.exists() ) {
---- server/duel.cpp.old 2006-09-11 22:48:30.000000000 +0200
-+++ server/duel.cpp 2006-09-11 22:48:57.000000000 +0200
-@@ -44,7 +44,7 @@
- {
- QDir folder;
-
-- folder.setPath( "./themes/" + THEME );
-+ folder.setPath( "@GENTOO_DATADIR@/themes/" + THEME );
- if( ! folder.exists() ) {
- folder.setPath( "/usr/local/share/games/attal/themes/" + THEME );
- if( ! folder.exists() ) {
diff --git a/games-strategy/attal/metadata.xml b/games-strategy/attal/metadata.xml
deleted file mode 100644
index ea58e232ebad..000000000000
--- a/games-strategy/attal/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
- </maintainer>
- <upstream>
- <remote-id type="sourceforge">attal</remote-id>
- </upstream>
-</pkgmetadata>