summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-drivers/xf86-video-r128/xf86-video-r128-6.12.0.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/x11-drivers/xf86-video-r128/xf86-video-r128-6.12.0.ebuild b/x11-drivers/xf86-video-r128/xf86-video-r128-6.12.0.ebuild
index 5d59f92a1cf6..51078786ca62 100644
--- a/x11-drivers/xf86-video-r128/xf86-video-r128-6.12.0.ebuild
+++ b/x11-drivers/xf86-video-r128/xf86-video-r128-6.12.0.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
XORG_DRI=dri
-inherit flag-o-matic xorg-2
+inherit flag-o-matic xorg-3
DESCRIPTION="ATI Rage128 video driver"
@@ -14,15 +15,12 @@ IUSE="dri"
RDEPEND=">=x11-base/xorg-server-1.2"
DEPEND="${RDEPEND}"
-pkg_setup() {
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable dri)
- )
-}
-
src_configure() {
# always use C11 semantics
append-cflags -std=gnu11
- xorg-2_src_configure
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable dri)
+ )
+ xorg-3_src_configure
}