summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-vpn/openvpn/openvpn-2.5.2-r2.ebuild (renamed from net-vpn/openvpn/openvpn-2.5.2-r1.ebuild)4
-rw-r--r--net-vpn/openvpn/openvpn-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/net-vpn/openvpn/openvpn-2.5.2-r1.ebuild b/net-vpn/openvpn/openvpn-2.5.2-r2.ebuild
index b446547b08c2..e09e6ac634dc 100644
--- a/net-vpn/openvpn/openvpn-2.5.2-r1.ebuild
+++ b/net-vpn/openvpn/openvpn-2.5.2-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools flag-o-matic systemd linux-info
+inherit autotools flag-o-matic systemd linux-info tmpfiles
DESCRIPTION="Robust and highly flexible tunneling application compatible with many OSes"
HOMEPAGE="https://openvpn.net/"
@@ -140,6 +140,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process openvpn.conf
+
if use x64-macos; then
elog "You might want to install tuntaposx for TAP interface support:"
elog "http://tuntaposx.sourceforge.net"
diff --git a/net-vpn/openvpn/openvpn-9999.ebuild b/net-vpn/openvpn/openvpn-9999.ebuild
index ac64c3e3d3c7..d5d643edb2fb 100644
--- a/net-vpn/openvpn/openvpn-9999.ebuild
+++ b/net-vpn/openvpn/openvpn-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools flag-o-matic systemd linux-info
+inherit autotools flag-o-matic systemd linux-info tmpfiles
DESCRIPTION="Robust and highly flexible tunneling application compatible with many OSes"
HOMEPAGE="https://openvpn.net/"
@@ -139,6 +139,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process openvpn.conf
+
if use x64-macos ; then
elog "You might want to install tuntaposx for TAP interface support:"
elog "http://tuntaposx.sourceforge.net"