summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-client/surf/Manifest2
-rw-r--r--www-client/surf/files/surf-0.6-gentoo.patch133
-rw-r--r--www-client/surf/files/surf-0.7-gentoo.patch84
-rw-r--r--www-client/surf/surf-0.6-r1.ebuild63
-rw-r--r--www-client/surf/surf-0.7-r1.ebuild72
5 files changed, 0 insertions, 354 deletions
diff --git a/www-client/surf/Manifest b/www-client/surf/Manifest
index ab5738436d7e..a9e0de2717d2 100644
--- a/www-client/surf/Manifest
+++ b/www-client/surf/Manifest
@@ -1,3 +1 @@
-DIST surf-0.6.tar.gz 14781 SHA256 fdc1ccfaee5c4f008eeb8fe5f9200d3ad71296e8d7af52bdd6a771f111866805 SHA512 f3550535351e37296280d33d229998e1f00aa605d0dab4a58944cf213721e823a1cfd9134b7bca2a4d61e265122a30d5dc917a290163ed8af2b24cd75d41a100 WHIRLPOOL 2a163d450b47b4964ce3686d76bf6e3a747984f0e86f84e2dccfa9d3e885bc26adf0100cdef48ae19d91f34a2d14d6c4950d2a7db7d333612e2b1fc48b077f99
-DIST surf-0.7.tar.gz 18792 SHA256 95608546fb64d01c7a8153c356be0e284ebe120c3c596a94eb3f3ad47e1c494a SHA512 a6a0e172d99f8ce5a7eb63bd34ef3e55ae26059cc94148cf7c50ac665a5e64d90f4a6b1e71b73c1fa763dfaef9b50aaae79e924724f564b2ddf2b8aef4268ff6 WHIRLPOOL 6dbda75a102e108fb0d2910018b0b622189d3729326ba7ce69c4995c599f0d041bc5add771bdd27444752b6e627fcff6c546259e8605189f465e825578a9949b
DIST surf-2.0.tar.gz 19056 SHA256 faee4c7a62c38fc9791eff1ad06787c3c9b2b79f338806827f5152a7bc54951d SHA512 75798bb189fa2c2c93827672089a86cf155aa7b5c7c1a0887a34817ca41763907e44a02f52947535d37a043f827d2c0fe75d16a3d172079f9cab8da341e4c0c5 WHIRLPOOL 5cb76a924b0f1e97727321515deb84661f72ee892a7a34ceccdcc13fd6b994572021411b29603056af3f48efbbe66ee3318eab0828eb4a129366a5b79498eb0b
diff --git a/www-client/surf/files/surf-0.6-gentoo.patch b/www-client/surf/files/surf-0.6-gentoo.patch
deleted file mode 100644
index cda644baa84e..000000000000
--- a/www-client/surf/files/surf-0.6-gentoo.patch
+++ /dev/null
@@ -1,133 +0,0 @@
---- a/config.mk
-+++ b/config.mk
-@@ -4,27 +4,27 @@
- # Customize below to fit your system
-
- # paths
--PREFIX = /usr/local
--MANPREFIX = ${PREFIX}/share/man
-+PREFIX = /usr
-+MANPREFIX = $(PREFIX)/share/man
-
--X11INC = /usr/X11R6/include
--X11LIB = /usr/X11R6/lib
-+X11INC = $(shell $(PKG_CONFIG) --cflags x11)
-+X11LIB = $(shell $(PKG_CONFIG) --libs x11)
-
--GTKINC = `pkg-config --cflags gtk+-2.0 webkit-1.0`
--GTKLIB = `pkg-config --libs gtk+-2.0 webkit-1.0`
-+GTKINC = $(shell $(PKG_CONFIG) --cflags gtk+-2.0 gthread-2.0 webkit-1.0)
-+GTKLIB = $(shell $(PKG_CONFIG) --libs gtk+-2.0 gthread-2.0 webkit-1.0)
-
- # includes and libs
--INCS = -I. -I/usr/include -I${X11INC} ${GTKINC}
--LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 ${GTKLIB} -lgthread-2.0
-+INCS = -I. -I/usr/include $(X11INC) $(GTKINC)
-+LIBS = $(X11LIB) $(GTKLIB)
-
- # flags
--CPPFLAGS = -DVERSION=\"${VERSION}\" -D_BSD_SOURCE
--CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
--LDFLAGS = -g ${LIBS}
-+CPPFLAGS = -DVERSION=\"$(VERSION)\" -D_BSD_SOURCE
-+CFLAGS += -std=c99 -pedantic -Wall $(INCS) $(CPPFLAGS)
-+LDFLAGS += $(LIBS)
-
- # Solaris
--#CFLAGS = -fast ${INCS} -DVERSION=\"${VERSION}\"
--#LDFLAGS = ${LIBS}
-+#CFLAGS = -fast $(INCS) -DVERSION=\"$(VERSION)\"
-+#LDFLAGS = $(LIBS)
-
- # compiler and linker
--CC = cc
-+CC ?= gcc
---- a/Makefile
-+++ b/Makefile
-@@ -4,58 +4,58 @@
- include config.mk
-
- SRC = surf.c
--OBJ = ${SRC:.c=.o}
-+OBJ = $(SRC:.c=.o)
-
- all: options surf
-
- options:
- @echo surf build options:
-- @echo "CFLAGS = ${CFLAGS}"
-- @echo "LDFLAGS = ${LDFLAGS}"
-- @echo "CC = ${CC}"
-+ @echo "CFLAGS = $(CFLAGS)"
-+ @echo "LDFLAGS = $(LDFLAGS)"
-+ @echo "CC = $(CC)"
-
- .c.o:
- @echo CC $<
-- @${CC} -c ${CFLAGS} $<
-+ $(CC) -c $(CFLAGS) $<
-
--${OBJ}: config.h config.mk
-+$(OBJ): config.h config.mk
-
- config.h:
- @echo creating $@ from config.def.h
-- @cp config.def.h $@
-+ cp config.def.h $@
-
--surf: ${OBJ}
-+surf: $(OBJ)
- @echo CC -o $@
-- @${CC} -o $@ surf.o ${LDFLAGS}
-+ $(CC) -o $@ surf.o $(LDFLAGS)
-
- clean:
- @echo cleaning
-- @rm -f surf ${OBJ} surf-${VERSION}.tar.gz
-+ rm -f surf $(OBJ) surf-$(VERSION).tar.gz
-
- dist: clean
- @echo creating dist tarball
-- @mkdir -p surf-${VERSION}
-- @cp -R LICENSE Makefile config.mk config.def.h README \
-+ mkdir -p surf-$(VERSION)
-+ cp -R LICENSE Makefile config.mk config.def.h README \
- surf-open.sh arg.h TODO.md surf.png \
-- surf.1 ${SRC} surf-${VERSION}
-- @tar -cf surf-${VERSION}.tar surf-${VERSION}
-- @gzip surf-${VERSION}.tar
-- @rm -rf surf-${VERSION}
-+ surf.1 $(SRC) surf-$(VERSION)
-+ tar -cf surf-$(VERSION).tar surf-$(VERSION)
-+ gzip surf-$(VERSION).tar
-+ rm -rf surf-$(VERSION)
-
- install: all
-- @echo installing executable file to ${DESTDIR}${PREFIX}/bin
-- @mkdir -p ${DESTDIR}${PREFIX}/bin
-- @cp -f surf ${DESTDIR}${PREFIX}/bin
-- @chmod 755 ${DESTDIR}${PREFIX}/bin/surf
-- @echo installing manual page to ${DESTDIR}${MANPREFIX}/man1
-- @mkdir -p ${DESTDIR}${MANPREFIX}/man1
-- @sed "s/VERSION/${VERSION}/g" < surf.1 > ${DESTDIR}${MANPREFIX}/man1/surf.1
-- @chmod 644 ${DESTDIR}${MANPREFIX}/man1/surf.1
-+ @echo installing executable file to $(DESTDIR)$(PREFIX)/bin
-+ mkdir -p $(DESTDIR)$(PREFIX)/bin
-+ cp -f surf $(DESTDIR)$(PREFIX)/bin
-+ chmod 755 $(DESTDIR)$(PREFIX)/bin/surf
-+ @echo installing manual page to $(DESTDIR)$(MANPREFIX)/man1
-+ mkdir -p $(DESTDIR)$(MANPREFIX)/man1
-+ sed "s/VERSION/$(VERSION)/g" < surf.1 > $(DESTDIR)$(MANPREFIX)/man1/surf.1
-+ chmod 644 $(DESTDIR)$(MANPREFIX)/man1/surf.1
-
- uninstall:
-- @echo removing executable file from ${DESTDIR}${PREFIX}/bin
-- @rm -f ${DESTDIR}${PREFIX}/bin/surf
-- @echo removing manual page from ${DESTDIR}${MANPREFIX}/man1
-- @rm -f ${DESTDIR}${MANPREFIX}/man1/surf.1
-+ @echo removing executable file from $(DESTDIR)$(PREFIX)/bin
-+ rm -f $(DESTDIR)$(PREFIX)/bin/surf
-+ @echo removing manual page from $(DESTDIR)$(MANPREFIX)/man1
-+ rm -f $(DESTDIR)$(MANPREFIX)/man1/surf.1
-
- .PHONY: all options clean dist install uninstall
diff --git a/www-client/surf/files/surf-0.7-gentoo.patch b/www-client/surf/files/surf-0.7-gentoo.patch
deleted file mode 100644
index 0be4598f1c46..000000000000
--- a/www-client/surf/files/surf-0.7-gentoo.patch
+++ /dev/null
@@ -1,84 +0,0 @@
---- a/config.mk
-+++ b/config.mk
-@@ -4,27 +4,27 @@
- # Customize below to fit your system
-
- # paths
--PREFIX = /usr/local
-+PREFIX = /usr
- MANPREFIX = ${PREFIX}/share/man
-
--X11INC = /usr/X11R6/include
--X11LIB = /usr/X11R6/lib
-+X11INC = $(shell $(PKG_CONFIG) --cflags x11)
-+X11LIB = $(shell $(PKG_CONFIG) --libs x11)
-
--GTKINC = `pkg-config --cflags gtk+-2.0 webkit-1.0`
--GTKLIB = `pkg-config --libs gtk+-2.0 webkit-1.0`
-+GTKINC = $(shell $(PKG_CONFIG) --cflags gtk+-2.0 gthread-2.0 webkit-1.0)
-+GTKLIB = $(shell $(PKG_CONFIG) --libs gtk+-2.0 gthread-2.0 webkit-1.0)
-
- # includes and libs
--INCS = -I. -I/usr/include -I${X11INC} ${GTKINC}
--LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 ${GTKLIB} -lgthread-2.0
-+INCS = -I. -I/usr/include ${X11INC} ${GTKINC}
-+LIBS = ${X11LIB} ${GTKLIB}
-
- # flags
- CPPFLAGS = -DVERSION=\"${VERSION}\" -D_DEFAULT_SOURCE
--CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
--LDFLAGS = -g ${LIBS}
-+CFLAGS = -std=c99 -pedantic -Wall ${INCS} ${CPPFLAGS}
-+LDFLAGS = ${LIBS}
-
- # Solaris
- #CFLAGS = -fast ${INCS} -DVERSION=\"${VERSION}\"
- #LDFLAGS = ${LIBS}
-
- # compiler and linker
--CC = cc
-+CC ?= cc
---- a/Makefile
-+++ b/Makefile
-@@ -15,18 +15,16 @@
- @echo "CC = ${CC}"
-
- .c.o:
-- @echo CC $<
-- @${CC} -c ${CFLAGS} $<
-+ ${CC} -c ${CFLAGS} $<
-
- ${OBJ}: config.h config.mk
-
- config.h:
- @echo creating $@ from config.def.h
-- @cp config.def.h $@
-+ cp config.def.h $@
-
- surf: ${OBJ}
-- @echo CC -o $@
-- @${CC} -o $@ surf.o ${LDFLAGS}
-+ ${CC} -o $@ surf.o ${LDFLAGS}
-
- clean:
- @echo cleaning
-@@ -44,13 +42,13 @@
-
- install: all
- @echo installing executable file to ${DESTDIR}${PREFIX}/bin
-- @mkdir -p ${DESTDIR}${PREFIX}/bin
-- @cp -f surf ${DESTDIR}${PREFIX}/bin
-- @chmod 755 ${DESTDIR}${PREFIX}/bin/surf
-+ mkdir -p ${DESTDIR}${PREFIX}/bin
-+ cp -f surf ${DESTDIR}${PREFIX}/bin
-+ chmod 755 ${DESTDIR}${PREFIX}/bin/surf
- @echo installing manual page to ${DESTDIR}${MANPREFIX}/man1
-- @mkdir -p ${DESTDIR}${MANPREFIX}/man1
-- @sed "s/VERSION/${VERSION}/g" < surf.1 > ${DESTDIR}${MANPREFIX}/man1/surf.1
-- @chmod 644 ${DESTDIR}${MANPREFIX}/man1/surf.1
-+ mkdir -p ${DESTDIR}${MANPREFIX}/man1
-+ sed "s/VERSION/${VERSION}/g" < surf.1 > ${DESTDIR}${MANPREFIX}/man1/surf.1
-+ chmod 644 ${DESTDIR}${MANPREFIX}/man1/surf.1
-
- uninstall:
- @echo removing executable file from ${DESTDIR}${PREFIX}/bin
diff --git a/www-client/surf/surf-0.6-r1.ebuild b/www-client/surf/surf-0.6-r1.ebuild
deleted file mode 100644
index 00244e9e1cdf..000000000000
--- a/www-client/surf/surf-0.6-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils savedconfig toolchain-funcs
-
-DESCRIPTION="a simple web browser based on WebKit/GTK+"
-HOMEPAGE="http://surf.suckless.org/"
-SRC_URI="http://dl.suckless.org/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-COMMON_DEPEND="
- dev-libs/glib:2
- net-libs/libsoup
- net-libs/webkit-gtk:2
- x11-libs/gtk+:2
- x11-libs/libX11
-"
-DEPEND="
- ${COMMON_DEPEND}
- virtual/pkgconfig
-"
-RDEPEND="
- !sci-chemistry/surf
- ${COMMON_DEPEND}
- x11-apps/xprop
- x11-misc/dmenu
-"
-
-pkg_setup() {
- if ! use savedconfig; then
- elog "The default config.h assumes you have"
- elog " net-misc/curl"
- elog " x11-terms/st"
- elog "installed to support the download function."
- elog "Without those, downloads will fail (gracefully)."
- elog "You can fix this by:"
- elog "1) Installing these packages, or"
- elog "2) Setting USE=savedconfig and changing config.h accordingly."
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
- epatch_user
- restore_config config.h
- tc-export CC PKG_CONFIG
-}
-
-src_install() {
- default
- save_config config.h
-}
-
-pkg_postinst() {
- if [[ ${REPLACING_VERSIONS} ]] && [[ ${REPLACING_VERSIONS} < 0.4.1-r1 ]]; then
- ewarn "Please correct the permissions of your \$HOME/.surf/ directory"
- ewarn "and its contents to no longer be world readable (see bug #404983)"
- fi
-}
diff --git a/www-client/surf/surf-0.7-r1.ebuild b/www-client/surf/surf-0.7-r1.ebuild
deleted file mode 100644
index d5f2405feb1d..000000000000
--- a/www-client/surf/surf-0.7-r1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit savedconfig toolchain-funcs
-
-DESCRIPTION="a simple web browser based on WebKit/GTK+"
-HOMEPAGE="http://surf.suckless.org/"
-SRC_URI="http://dl.suckless.org/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-COMMON_DEPEND="
- dev-libs/glib:2
- net-libs/libsoup
- net-libs/webkit-gtk:2
- x11-libs/gtk+:2
- x11-libs/libX11
-"
-DEPEND="
- ${COMMON_DEPEND}
- virtual/pkgconfig
-"
-RDEPEND="
- !sci-chemistry/surf
- ${COMMON_DEPEND}
- x11-apps/xprop
- x11-misc/dmenu
- !savedconfig? (
- net-misc/curl
- x11-terms/st
- )
-"
-PATCHES=(
- "${FILESDIR}"/${PN}-0.7-gentoo.patch
-)
-
-pkg_setup() {
- if ! use savedconfig; then
- elog "The default config.h assumes you have"
- elog " net-misc/curl"
- elog " x11-terms/st"
- elog "installed to support the download function."
- elog "Without those, downloads will fail (gracefully)."
- elog "You can fix this by:"
- elog "1) Installing these packages, or"
- elog "2) Setting USE=savedconfig and changing config.h accordingly."
- fi
-}
-
-src_prepare() {
- default
-
- restore_config config.h
-
- tc-export CC PKG_CONFIG
-}
-
-src_install() {
- default
-
- save_config config.h
-}
-
-pkg_postinst() {
- if [[ ${REPLACING_VERSIONS} ]] && [[ ${REPLACING_VERSIONS} < 0.4.1-r1 ]]; then
- ewarn "Please correct the permissions of your \$HOME/.surf/ directory"
- ewarn "and its contents to no longer be world readable (see bug #404983)"
- fi
-}