summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/barcode/barcode-0.99-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/app-text/barcode/barcode-0.99-r1.ebuild b/app-text/barcode/barcode-0.99-r1.ebuild
index 9defd1531f06..51debbbbb972 100644
--- a/app-text/barcode/barcode-0.99-r1.ebuild
+++ b/app-text/barcode/barcode-0.99-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit autotools
+
DESCRIPTION="barcode generator"
HOMEPAGE="https://www.gnu.org/software/barcode/"
SRC_URI="mirror://gnu/barcode/${P}.tar.gz"
@@ -20,13 +22,15 @@ PATCHES=(
)
src_prepare() {
+ default
+
sed -i -e '/^LDFLAGS =/s:=:+=:' \
-e "/^aLIBDIR/s:lib:$(get_libdir):" \
-e '/^INFODIR/s:info:share/info:' \
-e '/^MAN/s:man:share/man:' \
Makefile.in || die
- default
+ eautoreconf
}
src_configure() {