summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/binwalk/Manifest3
-rw-r--r--app-misc/binwalk/binwalk-2.3.6.ebuild37
-rw-r--r--app-misc/binwalk/binwalk-2.4.1.ebuild (renamed from app-misc/binwalk/binwalk-2.3.8.ebuild)4
-rw-r--r--app-misc/binwalk/binwalk-9999.ebuild4
-rw-r--r--dev-python/agate/Manifest1
-rw-r--r--dev-python/agate/agate-1.10.1.ebuild45
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.100.2.ebuild91
-rw-r--r--dev-python/moto/Manifest1
-rw-r--r--dev-python/moto/moto-5.0.6.ebuild153
10 files changed, 297 insertions, 43 deletions
diff --git a/app-misc/binwalk/Manifest b/app-misc/binwalk/Manifest
index ce797b05909f..fdd9fbae0916 100644
--- a/app-misc/binwalk/Manifest
+++ b/app-misc/binwalk/Manifest
@@ -1,3 +1,2 @@
-DIST binwalk-2.3.6.tar.gz 39723335 BLAKE2B 20710dc32f67981b1ba69ced649bfddc0247b9054a30ba9a8ab17710094fa4f45a44b32b18e2de6e0c63d632044432e8d4a8ec8cdacb007996b7d91b983547bc SHA512 05e06682a9b8aa6b68b580b6818a2f08d8d81d89961f6cacfd9d14185c26727bbdf6dedb2f26079fffebf7de6f45002944ed8f3475ba04e4b05ac6d5c19560ea
-DIST binwalk-2.3.8.tar.gz 39723354 BLAKE2B 87c4e9e78e7a2c6132266ad9bd4ba1cfc05fccb078b41b7a9890c59586175c1993bea5c642493c42c10d3e2af36965c88612c881fec750eb7d99b260226ae65f SHA512 5b99626496ae236f32ae190372b4e24dbb3873413bc822a67096fb380139835379556987cfd6f7561a8b36574ec4d4ea8007182edb6d58ac1cd993cafb46d1a7
DIST binwalk-2.4.0.tar.gz 39744574 BLAKE2B 8503e86afb584e431b25611fbed91e85aaf307e9011b5ef09a83b5f4756a815f9d3de67d440a2b7547cbe162d1940e8d6ffc4899afac14ccb938304002b1eb41 SHA512 41bee6a0d1cd587f81dcf81c30215a305b61e4db208bc9d8e4f0b9f12acb47e4dc2e6af23e06118ef6e30c484f6be743b456b6d4324be4388413ff291682345e
+DIST binwalk-2.4.1.tar.gz 39747760 BLAKE2B 480f8ff06932c77ca5ab2857cddf7ecebb36b6f2e55e3ccf15a971fa0f4c59d57b652556fd9f0dd20e6fbd887fdef3c6da022f76787b2edf16b0d1714d291e8a SHA512 f83d0ca09a39033944ce16345b7c2c8f3051a20f80315e4c797221df4e6844c7c89c0a49053d739156e2654b482d6ef93f0814fa588daab031dbeaed1423e6f2
diff --git a/app-misc/binwalk/binwalk-2.3.6.ebuild b/app-misc/binwalk/binwalk-2.3.6.ebuild
deleted file mode 100644
index d77b715b9380..000000000000
--- a/app-misc/binwalk/binwalk-2.3.6.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/OSPG/binwalk.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/OSPG/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv x86 ~x64-macos"
-fi
-
-DESCRIPTION="A tool for identifying files embedded inside firmware images"
-HOMEPAGE="https://github.com/ReFirmLabs/binwalk"
-
-LICENSE="MIT"
-SLOT="0"
-
-distutils_enable_tests pytest
-
-python_install_all() {
- local DOCS=( API.md INSTALL.md README.md )
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "binwalk has many optional dependencies to automatically"
- elog "extract/decompress data, see INSTALL.md for more details."
- fi
-}
diff --git a/app-misc/binwalk/binwalk-2.3.8.ebuild b/app-misc/binwalk/binwalk-2.4.1.ebuild
index 53c023e8014b..e628cb990f4e 100644
--- a/app-misc/binwalk/binwalk-2.3.8.ebuild
+++ b/app-misc/binwalk/binwalk-2.4.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1 optfeature
@@ -34,7 +34,7 @@ pkg_postinst() {
optfeature "disassembly" dev-libs/capstone[python]
if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "binwalk has many optional dependencies to automatically"
+ elog "binwalk has many more optional dependencies to automatically"
elog "extract/decompress data, see INSTALL.md for more details."
fi
}
diff --git a/app-misc/binwalk/binwalk-9999.ebuild b/app-misc/binwalk/binwalk-9999.ebuild
index 53c023e8014b..e628cb990f4e 100644
--- a/app-misc/binwalk/binwalk-9999.ebuild
+++ b/app-misc/binwalk/binwalk-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1 optfeature
@@ -34,7 +34,7 @@ pkg_postinst() {
optfeature "disassembly" dev-libs/capstone[python]
if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "binwalk has many optional dependencies to automatically"
+ elog "binwalk has many more optional dependencies to automatically"
elog "extract/decompress data, see INSTALL.md for more details."
fi
}
diff --git a/dev-python/agate/Manifest b/dev-python/agate/Manifest
index e1fa3980abe4..bcd2767c04db 100644
--- a/dev-python/agate/Manifest
+++ b/dev-python/agate/Manifest
@@ -1,2 +1,3 @@
DIST agate-1.10.0.tar.gz 202845 BLAKE2B da462a47d8b33e6b5948bc16a9c236ee62c92d56f49df8a7e60cebc84b2d4d828f986f6f0975d24d1d513e1e8023dd5e570f77ff6ae233533ab1ac3c512fac81 SHA512 37e09f1fcccd5df9183cfd32f13bf23efad7987a3d71600e52b1b3bc9de8669640aa50f045c975c0fc8958cbe9df193e17f0ea52c1933782cca95ac267f794f9
+DIST agate-1.10.1.tar.gz 203139 BLAKE2B 656cc5f9abcc38848560bb81a9e7b1a8cf498897ea49a98bd3b44f3d625c69047ef3fa32b4a7191d8807c1bee29bd0c5a8d0ed99e1b91e30ea294b8fb436fb3d SHA512 b039fa587d1fc49277860f9876ad1f885f2530e82888ad8a32066f35e3086b5da0cb7aa9a2ed09ea7992efe649d32df27a372f85e4a06e8aca0d6ec8651567b5
DIST agate-1.9.1.tar.gz 202303 BLAKE2B a5e62ca5fdf8dc6e1b7393da3efa0432a2d7a89bcb2af744458ae04446ea85941968f1ee75facc6b29de9fdec92f9432d2b939392edbfadc5c0598a91feb9f76 SHA512 f8bbe9ed24c786063a1d99aa408a2e5b4841dd9d804004b8c74a272d564432013e0ddebc5325e73893c53a60636d64f27f2e64ad624a468a070cf6a8833b8620
diff --git a/dev-python/agate/agate-1.10.1.ebuild b/dev-python/agate/agate-1.10.1.ebuild
new file mode 100644
index 000000000000..baca934b9901
--- /dev/null
+++ b/dev-python/agate/agate-1.10.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python data analysis library that is optimized for humans instead of machines"
+HOMEPAGE="
+ https://github.com/wireservice/agate/
+ https://pypi.org/project/agate/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytimeparse-1.1.5[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.1[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.0[${PYTHON_USEDEP}]
+ >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/pyicu-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/python-slugify-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/leather-0.3.3-r2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/cssselect-0.9.1[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/furo
+
+EPYTEST_DESELECT=(
+ # require specific locales
+ tests/test_data_types.py::TestDate::test_cast_format_locale
+ tests/test_data_types.py::TestDateTime::test_cast_format_locale
+)
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index eaeb033fe31f..c9569aff6b8e 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1 +1,2 @@
DIST hypothesis-6.100.1.gh.tar.gz 9450717 BLAKE2B b27e3be6b43ee7d140ee00064748cd651683414b1b9f8d697c166ddec7596c11e2c47a814de91b567b4d08568e7bcaab42a88665f8b6882d2807afcfdb967257 SHA512 4b46c5dfb330c65c8fc4afce90ed28309fc377e39d65b1ba0bf086efb5fe53b2be021bcb5e6a90fa6bdad463de6254761faab14fe2ad7814e84dfff08ff1a9d9
+DIST hypothesis-6.100.2.gh.tar.gz 9452773 BLAKE2B 46519695d9fdefeeb3c24abacfb0dd495003c21e02b154a5873f1a0ec1f9ba04998398fd7a29c570b15f2fcce95e5ca9451687c37aae2e2b27190534480f8c4e SHA512 ba4cbc3ee7cb958e32c59cfba095eafe8108f5a614316bf490105939e7c487bd56890794aa5d9583feeb4a0b7852a966da16f7e4fac1721f55eb105d03637cbe
diff --git a/dev-python/hypothesis/hypothesis-6.100.2.ebuild b/dev-python/hypothesis/hypothesis-6.100.2.ebuild
new file mode 100644
index 000000000000..13d62b8d6bd1
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.100.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" --dist=worksteal \
+ tests/cover tests/pytest tests/quality
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index 514b7c2d7fae..a91046b3dfa5 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -3,3 +3,4 @@ DIST moto-5.0.2.tar.gz 4948857 BLAKE2B 664da28791bbf65eae9f76f59fd62f9c53aeb615c
DIST moto-5.0.3.tar.gz 4984811 BLAKE2B cfa8f70ca403d995b97dc6b5e0e6bcdeb4383ce76c1a333a7b047dccbca2d9e46bf9622d36720eee6fc0c917292542b154a326df863b45451a3ce72038b6e1c4 SHA512 c509795a7b00eec6adf9107ac541f8d4300fb2bd75459e9fb5e57f55843430d3a05eab85bd4f12ee6dbf88602ca8c185165a0b46d11973ad18c12a8bfe44dacf
DIST moto-5.0.4.tar.gz 5174431 BLAKE2B 03fb18cb63e0c7ccc0239bb27388b3e1190c078828e229ac88fee9fb0b8113b2bfac0c2f9abda4d9e67fe44b37a12e0ba7a8f8fa5c3973f0fa82dbf8ed763048 SHA512 65209c85895780bcfdcdc13d4cc0c64862e28fd3aefa6e265c86af6a320f554d5a58cb46b6c059d1288edc902b8069dc81e38b025238ec4340c485943dab5202
DIST moto-5.0.5.tar.gz 5188450 BLAKE2B 052cb9cbc5752ce46283f4d3fd43e92ba3a492437d19e6284eb6907dfc4dc84e50ac6b64f0c78df3f8b1dd8140008528bd00090e112f6642b9acebe8e268e8a0 SHA512 c3c57d79864e63abae128c6d683314d06b6ee9fd40e496485e8499196b54df5e7281abb0d0ca6f5f096685799041552becfd2404a0828964232246868c70adb9
+DIST moto-5.0.6.tar.gz 5212834 BLAKE2B 8bd5734c0c7615e2ca42f715e8865989ce8a07a2733dbc8f9bce3d3c8e4718543cbbc37cc342620ecf51df64f23c21f237f32a56f165f751472bd2b793140606 SHA512 41a29faf5a206690197315693a91d0e9a71ccb24dbbd790f568502d91a0b40cad0fbea60f6af75412f4e6cb11da00677db24dfc9c3d0a884533b39e4904e2ec3
diff --git a/dev-python/moto/moto-5.0.6.ebuild b/dev-python/moto/moto-5.0.6.ebuild
new file mode 100644
index 000000000000..31ff40e7e342
--- /dev/null
+++ b/dev-python/moto/moto-5.0.6.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="
+ https://github.com/getmoto/moto/
+ https://pypi.org/project/moto/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-xray-sdk-0.93[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]
+ >=dev-python/botocore-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/cfn-lint-0.40.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ >=dev-python/docker-3.0.0[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-cors[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3.0.7[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.5.0[${PYTHON_USEDEP}]
+ dev-python/pyaml[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.15.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5[${PYTHON_USEDEP}]
+ dev-python/sshpubkeys[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_firehose/test_firehose_put.py::test_put_record_http_destination
+ tests/test_firehose/test_firehose_put.py::test_put_record_batch_http_destination
+ # broken code (local variable used referenced before definition)
+ tests/test_appsync/test_appsync_schema.py
+ # Needs network (or docker?) but not marked as such, bug #807031
+ # TODO: report upstream
+ tests/test_awslambda/test_lambda_layers_invoked.py::test_invoke_local_lambda_layers
+ tests/test_batch/test_batch_jobs.py::test_cancel_pending_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_running_job
+ tests/test_batch/test_batch_jobs.py::test_container_overrides
+ tests/test_batch/test_batch_jobs.py::test_dependencies
+ tests/test_batch/test_batch_jobs.py::test_failed_dependencies
+ tests/test_batch/test_batch_jobs.py::test_failed_job
+ tests/test_batch/test_batch_jobs.py::test_submit_job_array_size
+ tests/test_batch/test_batch_jobs.py::test_terminate_job
+ tests/test_batch/test_batch_jobs.py::test_terminate_nonexisting_job
+ tests/test_cloudformation/test_cloudformation_custom_resources.py::test_create_custom_lambda_resource__verify_cfnresponse_failed
+
+ tests/test_cloudformation/test_cloudformation_stack_integration.py::test_lambda_function
+ tests/test_core/test_docker.py::test_docker_is_running_and_available
+ tests/test_core/test_request_passthrough.py
+ tests/test_core/test_responses_module.py::TestResponsesMockWithPassThru::test_aws_and_http_requests
+ tests/test_core/test_responses_module.py::TestResponsesMockWithPassThru::test_http_requests
+ tests/test_events/test_events_lambdatriggers_integration.py::test_creating_bucket__invokes_lambda
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events0-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events1-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events3-ObjectCreated:Put]"
+ # TODO
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_queue
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_fifo_queue
+ # require py_partiql_parser
+ tests/test_s3/test_s3_select.py
+ tests/test_dynamodb/test_dynamodb_statements.py
+ # require joserfc
+ tests/test_apigateway/test_apigateway.py::test_update_authorizer_configuration
+ tests/test_apigateway/test_apigateway.py::test_create_authorizer
+ tests/test_apigateway/test_apigateway.py::test_delete_authorizer
+ tests/test_cognitoidp/test_cognitoidp_exceptions.py::TestCognitoUserDeleter::test_authenticate_with_signed_out_user
+ No
+ tests/test_cognitoidp/test_cognitoidp_exceptions.py::TestCognitoUserPoolDuplidateEmails::test_use_existing_email__when_email_is_
+ -
+ tests/test_cognitoidp/test_cognitoidp_exceptions.py::TestCognitoUserPoolDuplidateEmails::test_use_existing_email__when_username_
+ -
+ tests/test_cognitoidp/test_cognitoidp_replay.py::TestCreateUserPoolWithPredeterminedID::test_different_seed
+ No
+ tests/test_cognitoidp/test_cognitoidp_replay.py::TestCreateUserPoolWithPredeterminedID::test_same_seed
+ tests/test_cognitoidp/test_server.py::test_sign_up_user_without_authentication
+ tests/test_cognitoidp/test_server.py::test_admin_create_user_without_authentication
+ )
+ local EPYTEST_IGNORE=(
+ # require joserfc
+ tests/test_cognitoidp/test_cognitoidp.py
+ # require antlr4 (which doesn't support py3.12)
+ tests/test_stepfunctions/parser
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x TZ=UTC
+
+ local serial_tests=(
+ # these tests set up credentials that are needed by the tests below
+ tests/test_core/test_importorder.py
+ # these tests apparently rely on some other test setting credentials
+ # up for them, so they need to be run separately, after the above
+ tests/test_awslambda_simple/test_lambda_simple.py::test_run_function{,_no_log}
+ tests/test_dynamodb/exceptions/test_dynamodb_exceptions.py
+ tests/test_dynamodb/exceptions/test_dynamodb_transactions.py::test_transaction_with_empty_key
+ tests/test_dynamodb/test_dynamodb.py::test_transact_write_items_failure__return_item
+ tests/test_dynamodb/test_dynamodb.py::test_transact_write_items_put_conditional_expressions
+ tests/test_dynamodb/test_dynamodb_update_expressions.py::test_update_different_map_elements_in_single_request
+ tests/test_events/test_events.py::test_start_replay_send_to_log_group
+ tests/test_lakeformation/test_resource_tags_integration.py
+ tests/test_redshiftdata
+ tests/test_resourcegroupstaggingapi/test_server.py::test_resourcegroupstaggingapi_list
+ tests/test_s3/test_s3.py::test_delete_bucket_cors
+ tests/test_s3/test_s3.py::test_delete_objects_percent_encoded
+ tests/test_s3/test_s3.py::test_delete_versioned_bucket_returns_metadata
+ tests/test_s3/test_s3_copyobject.py::test_copy_key_boto3_with_args
+ tests/test_s3/test_s3_copyobject.py::test_copy_key_boto3_with_args__using_multipart
+ tests/test_s3/test_s3_file_handles.py::TestS3FileHandleClosuresUsingMocks
+ tests/test_s3/test_s3_list_object_versions.py
+ tests/test_s3/test_s3_tagging.py
+ tests/test_s3control/test_s3control_access_points.py::test_delete_access_point
+ tests/test_utilities/test_threaded_server.py::TestThreadedMotoServer::test_server_can_handle_multiple_services
+ tests/test_utilities/test_threaded_server.py::TestThreadedMotoServer::test_server_is_reachable
+ )
+
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ EPYTEST_DESELECT+=( "${serial_tests[@]}" )
+ epytest -m 'not network'
+}