summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-arcade/bloboats/bloboats-1.0.2.ebuild3
-rw-r--r--games-arcade/bloboats/files/bloboats-1.0.2-gcc6.patch12
2 files changed, 14 insertions, 1 deletions
diff --git a/games-arcade/bloboats/bloboats-1.0.2.ebuild b/games-arcade/bloboats/bloboats-1.0.2.ebuild
index 0c138da1f23b..579487f2cdf4 100644
--- a/games-arcade/bloboats/bloboats-1.0.2.ebuild
+++ b/games-arcade/bloboats/bloboats-1.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -24,6 +24,7 @@ RDEPEND="${DEPEND}"
src_prepare() {
epatch "${FILESDIR}"/${P}-warnings.patch
+ epatch "${FILESDIR}"/${P}-gcc6.patch
sed -i \
-e "/PREFIX/s://:${D}:" \
-e "/DATADIR/s:/usr/games/bloboats/data:${GAMES_DATADIR}/${PN}:" \
diff --git a/games-arcade/bloboats/files/bloboats-1.0.2-gcc6.patch b/games-arcade/bloboats/files/bloboats-1.0.2-gcc6.patch
new file mode 100644
index 000000000000..e0af90f19cc3
--- /dev/null
+++ b/games-arcade/bloboats/files/bloboats-1.0.2-gcc6.patch
@@ -0,0 +1,12 @@
+diff -ruN --strip-trailing-cr bloboats-1.0.2.orig/src/menu.cpp bloboats-1.0.2/src/menu.cpp
+--- bloboats-1.0.2.orig/src/menu.cpp 2010-08-25 23:55:26.000000000 +0200
++++ bloboats-1.0.2/src/menu.cpp 2017-10-02 16:09:23.398499565 +0200
+@@ -917,7 +917,7 @@
+ exit(1);
+ }
+
+- ghostfile=false;
++ ghostfile=NULL;
+ ghost=false;
+ } else {
+ Uint32 ghostlevel = 0;