summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-calculators/tilp2/Manifest1
-rw-r--r--sci-calculators/tilp2/tilp2-1.18.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sci-calculators/tilp2/Manifest b/sci-calculators/tilp2/Manifest
index 164ebb3f3698..527a1e9c966f 100644
--- a/sci-calculators/tilp2/Manifest
+++ b/sci-calculators/tilp2/Manifest
@@ -1 +1,2 @@
DIST tilp2-1.17.tar.bz2 892549 SHA256 0bc744463450843c0f1e9deebf45af84a282304aff37865077ca7146d54ff6e7 SHA512 78f0242710a8c86a6db7d764e6e524b373aef0384f649b0e538ac1f4a57044fc9adf3aa32da9dc69509b6d835d020026bbdf574cdbb7f1f5a53ab316b987c572 WHIRLPOOL 4e6414d36996f59da39911aea7acdd0afbd37bb5131f8c7c5d14e1d683f788634194e5fad809d18fe19c217846c44ae747495de0a58ff4583847c5168a34a368
+DIST tilp2-1.18.tar.bz2 536744 SHA256 7b3ab363eeb52504d6ef5811c5d264f8016060bb7bd427be5a064c2ed7384e47 SHA512 8e46337e1ac7de85d88d4cb677910a099cdb6d3f473cdf8ca751a45dd66410b11751cd4555116c9249aa53bd23105957b4b2af2247968ec840da68aeed105f5f WHIRLPOOL f89ee4f52d87eed99160ddd1ed290e7b84f2cf499d35240e675186bd0f3d674fd59cab71b4791fa76148152322901f899761b310b1f8ea5489c54b45261c61b1
diff --git a/sci-calculators/tilp2/tilp2-1.18.ebuild b/sci-calculators/tilp2/tilp2-1.18.ebuild
new file mode 100644
index 000000000000..8b43e5d17e17
--- /dev/null
+++ b/sci-calculators/tilp2/tilp2-1.18.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Communication program for Texas Instruments calculators "
+HOMEPAGE="http://lpg.ticalc.org/prj_tilp"
+SRC_URI="mirror://sourceforge/tilp/tilp2-linux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="nls static-libs"
+
+RDEPEND="
+ dev-libs/glib:2
+ gnome-base/libglade:2.0
+ >=sci-libs/libticalcs2-1.1.9
+ >=sci-libs/libticables2-1.3.5
+ >=sci-libs/libtifiles2-1.1.7
+ >=sci-libs/libticonv-1.1.5
+ x11-libs/gtk+:2
+ nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+ # The ac macro AC_PATH_KDE was provided by "acinclude.m4" in 1.17.
+ # This file is missing in the current version which will cause an autoconf error.
+ # But since we don't build with kde support, we may safely remove all its reverse dependencies.
+ sed -i -e '/AC_PATH_KDE/d' configure.ac
+ sed -i \
+ -e 's/@[^@]*\(KDE\|QT\|KIO\)[^@]*@//g' \
+ -e 's/@X_LDFLAGS@//g' \
+ src/Makefile.am
+ eautoreconf
+}
+
+src_configure() {
+ # kde seems to be kde3 only
+ econf --without-kde \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}