summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/syncthing/files/syncthing-1.3.4-TestIssue5063_timeout.patch18
-rw-r--r--net-p2p/syncthing/syncthing-1.3.4-r1.ebuild4
-rw-r--r--net-p2p/syncthing/syncthing-1.4.2.ebuild4
3 files changed, 26 insertions, 0 deletions
diff --git a/net-p2p/syncthing/files/syncthing-1.3.4-TestIssue5063_timeout.patch b/net-p2p/syncthing/files/syncthing-1.3.4-TestIssue5063_timeout.patch
new file mode 100644
index 000000000000..3148dc8a976c
--- /dev/null
+++ b/net-p2p/syncthing/files/syncthing-1.3.4-TestIssue5063_timeout.patch
@@ -0,0 +1,18 @@
+As of early April 2020, running the Syncthing test suite on the Gentoo ppc64
+buildhost fails due to TestIssue5063 timing out. Increase the time-out
+threshold for this test to allow it to pass.
+
+Other arches we currently support (i.e. amd64, arm and x86) shouldn't be
+affected by the change because thay have always passed so far anyway.
+
+--- a/lib/model/model_test.go
++++ b/lib/model/model_test.go
+@@ -914,7 +914,7 @@
+ }()
+ select {
+ case <-finished:
+- case <-time.After(10 * time.Second):
++ case <-time.After(20 * time.Second):
+ pprof.Lookup("goroutine").WriteTo(os.Stdout, 1)
+ t.Fatal("Timed out before all devices were added")
+ }
diff --git a/net-p2p/syncthing/syncthing-1.3.4-r1.ebuild b/net-p2p/syncthing/syncthing-1.3.4-r1.ebuild
index 57a69fe4269c..8027187afc57 100644
--- a/net-p2p/syncthing/syncthing-1.3.4-r1.ebuild
+++ b/net-p2p/syncthing/syncthing-1.3.4-r1.ebuild
@@ -292,6 +292,10 @@ RDEPEND="acct-group/syncthing
DOCS=( README.md AUTHORS CONTRIBUTING.md )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.4-TestIssue5063_timeout.patch
+)
+
src_prepare() {
# Bug #679280
xdg_environment_reset
diff --git a/net-p2p/syncthing/syncthing-1.4.2.ebuild b/net-p2p/syncthing/syncthing-1.4.2.ebuild
index 7b3436014f4d..5047b42159ab 100644
--- a/net-p2p/syncthing/syncthing-1.4.2.ebuild
+++ b/net-p2p/syncthing/syncthing-1.4.2.ebuild
@@ -306,6 +306,10 @@ RDEPEND="acct-group/syncthing
DOCS=( README.md AUTHORS CONTRIBUTING.md )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.4-TestIssue5063_timeout.patch
+)
+
src_prepare() {
# Bug #679280
xdg_environment_reset