summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-i18n/libskk/Manifest1
-rw-r--r--app-i18n/libskk/libskk-1.0.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-i18n/libskk/Manifest b/app-i18n/libskk/Manifest
index 0f65599462d9..1664f7afa1e4 100644
--- a/app-i18n/libskk/Manifest
+++ b/app-i18n/libskk/Manifest
@@ -1 +1,2 @@
DIST libskk-1.0.1.tar.gz 860453 SHA256 37bb7859deffd038319a8bc7f9c7d3b207d7dce6afea5e3da519381d7a05388c SHA512 17dc7c0361083c08c29267b4fe2d066b079e5156728f461717044f99579ec2674b56c960d2be5a42a2dffb693106d2d3d78ec8cb833e8f189d48e421a25d91b0 WHIRLPOOL c40970c33b807ee37e27888dda7220ed4e979a05a18c742f0fbfe39444192363b82d2e4b10f837b015ae8d0e359c4e67f7e548269b5b032a3e944f1ca0ff7791
+DIST libskk-1.0.2.tar.gz 867572 SHA256 e4e0a13493cf3a8ac87a4724dfdddfd2ae795659cbb3431bf94719fd6e016d40 SHA512 f8fff94b216c18f66bf1004ee068f8d737177f1b70ac36d054d9a68ce02ba9b8d1b7b4127d9a330f64054b2fe06f352070c750a3562d4be36fecf20cb854e6c0 WHIRLPOOL 5f56466be5c197e3bf5b920cd9eac150274bc5779d3d0a758197133b3c824df7b6e317aa0320ba15850f0d02b79853f9a41da75c43567ad8dc75119a49455460
diff --git a/app-i18n/libskk/libskk-1.0.2.ebuild b/app-i18n/libskk/libskk-1.0.2.ebuild
new file mode 100644
index 000000000000..c03b9f52026e
--- /dev/null
+++ b/app-i18n/libskk/libskk-1.0.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit ltprune virtualx vala
+
+DESCRIPTION="GObject-based library to deal with Japanese kana-to-kanji conversion method"
+HOMEPAGE="https://github.com/ueno/libskk"
+SRC_URI="https://github.com/ueno/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection nls static-libs"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/json-glib
+ dev-libs/libgee:0.8
+ introspection? ( dev-libs/gobject-introspection )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-util/intltool
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ vala_src_prepare
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable introspection) \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}