summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/ptyprocess/ptyprocess-0.5-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/ptyprocess/ptyprocess-0.5-r1.ebuild b/dev-python/ptyprocess/ptyprocess-0.5-r1.ebuild
new file mode 100644
index 000000000000..1c1b3c9f50c6
--- /dev/null
+++ b/dev-python/ptyprocess/ptyprocess-0.5-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Run a subprocess in a pseudo terminal"
+HOMEPAGE="https://github.com/pexpect/ptyprocess"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test --verbose --verbose || die
+}