summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/graphite2/Manifest1
-rw-r--r--media-gfx/graphite2/graphite2-1.3.14-r1.ebuild127
-rw-r--r--media-gfx/graphite2/graphite2-1.3.14_p20210810.ebuild123
3 files changed, 0 insertions, 251 deletions
diff --git a/media-gfx/graphite2/Manifest b/media-gfx/graphite2/Manifest
index c8a6a1cb288e..1700ba29e981 100644
--- a/media-gfx/graphite2/Manifest
+++ b/media-gfx/graphite2/Manifest
@@ -1,2 +1 @@
-DIST graphite2-1.3.14.tgz 6630061 BLAKE2B 72bf6736aaa8476a89e44ef53c5b6c94f45d815fe1a451ba6b3696bfe023971210975dee4a9c8cb3042f36442e4efecf5baf171ef4230ad2b10694a89865f918 SHA512 14b5eb2ba8158b8b62ffa7fb142100a0af1de0f0c45b2673801b636714a106b46fcd423b05c722d963c9543fafcf10fec811975308211a54f20a3ba322d7b295
DIST graphite2-1.3.14_p20210810.tar.gz 6656693 BLAKE2B 63a7d96b58f2779d8a4a353e1a986212b884fdf780fedcb83b22dcef2f7678d44c88c14ece2d09dc745df505a4a3825ce61d7c84bd05fd4e98c23d6e86e9326d SHA512 be54c1386578970cf65c1860336a113268181753c1e2a139e37ceeafcfa76e3162086879c54094d70cd0d36ad5852a95390aaa69572d875921e9481f1ae508ff
diff --git a/media-gfx/graphite2/graphite2-1.3.14-r1.ebuild b/media-gfx/graphite2/graphite2-1.3.14-r1.ebuild
deleted file mode 100644
index a7f8c0258cdd..000000000000
--- a/media-gfx/graphite2/graphite2-1.3.14-r1.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CMAKE_ECLASS=cmake
-GENTOO_DEPEND_ON_PERL="no"
-PYTHON_COMPAT=( python3_{7,8,9} )
-inherit perl-module python-any-r1 cmake-multilib
-
-DESCRIPTION="Library providing rendering capabilities for complex non-Roman writing systems"
-HOMEPAGE="https://scripts.sil.org/cms/scripts/page.php?site_id=projects&item_id=graphite_home"
-SRC_URI="mirror://sourceforge/silgraphite/${PN}/${P}.tgz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="perl test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="perl? ( dev-lang/perl:= )"
-DEPEND="
- perl? ( dev-lang/perl:= )
- test? ( dev-libs/glib:2 )
-"
-BDEPEND="
- perl? (
- dev-lang/perl
- dev-perl/Locale-Maketext-Lexicon
- dev-perl/Module-Build
- )
- test? (
- ${PYTHON_DEPS}
- $(python_gen_any_dep 'dev-python/fonttools[${PYTHON_USEDEP}]')
- media-libs/fontconfig
- perl? ( virtual/perl-Test-Simple )
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.3.5-includes-libs-perl.patch"
- "${FILESDIR}/${PN}-1.35-fix-gcc-linking.patch"
- "${FILESDIR}/${PN}-1.3.14-fix-cmake-files-libdir.patch"
-)
-
-pkg_setup() {
- use perl && perl_set_version
- use test && python-any-r1_pkg_setup
-}
-
-python_check_deps() {
- has_version -b "dev-python/fonttools[${PYTHON_USEDEP}]"
-}
-
-src_prepare() {
- cmake_src_prepare
-
- # make tests optional
- if ! use test; then
- sed -e '/tests/d' -i CMakeLists.txt || die
- fi
-}
-
-multilib_src_configure() {
- local mycmakeargs=(
- # Renamed VM_MACHINE_TYPE to GRAPHITE2_VM_TYPE
- -DGRAPHITE2_VM_TYPE=direct
- )
- # https://sourceforge.net/p/silgraphite/bugs/49/
- [[ ${CHOST} == powerpc*-apple* ]] && mycmakeargs+=(
- -DGRAPHITE2_NSEGCACHE:BOOL=ON
- )
-
- if use elibc_musl ; then
- # bug #829690
- if use ppc || use x86 ; then
- sed -i -e 's:${GRAPHITE_LINK_FLAGS}:-lssp_nonshared &:' "${S}"/src/CMakeLists.txt || die
- fi
- fi
-
- cmake_src_configure
-
- # fix perl linking
- if multilib_is_native_abi && use perl; then
- # we rely on the fact that cmake_src_configure sets BUILD_DIR
- sed -e "s:@BUILD_DIR@:\"${BUILD_DIR}/src\":" \
- -i "${S}"/contrib/perl/Build.PL || die
- fi
-}
-
-src_compile() {
- cmake-multilib_src_compile
- if use perl; then
- cd contrib/perl || die
- perl-module_src_configure
- perl-module_src_compile
- fi
-}
-
-multilib_src_test() {
- if multilib_is_native_abi; then
- cmake_src_test
- else
- einfo "Cannot test since python is not multilib."
- fi
-}
-
-src_test() {
- cmake-multilib_src_test
- if use perl; then
- # Perl tests fail due to missing POD coverage...
- perl_rm_files "contrib/perl/t/pod.t" "contrib/perl/t/pod-coverage.t"
- cd contrib/perl || die
- perl-module_src_test
- fi
-}
-
-src_install() {
- cmake-multilib_src_install
- if use perl; then
- cd contrib/perl || die
- perl-module_src_install
- perl_delete_localpod
- fi
-
- find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
-}
diff --git a/media-gfx/graphite2/graphite2-1.3.14_p20210810.ebuild b/media-gfx/graphite2/graphite2-1.3.14_p20210810.ebuild
deleted file mode 100644
index 47a0ef22b350..000000000000
--- a/media-gfx/graphite2/graphite2-1.3.14_p20210810.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-COMMIT=80c52493ef42e6fe605a69dcddd2a691cd8a1380
-GENTOO_DEPEND_ON_PERL="no"
-PYTHON_COMPAT=( python3_{8..10} )
-inherit perl-module python-any-r1 cmake-multilib
-
-DESCRIPTION="Library providing rendering capabilities for complex non-Roman writing systems"
-HOMEPAGE="https://scripts.sil.org/cms/scripts/page.php?site_id=projects&item_id=graphite_home"
-SRC_URI="https://github.com/silnrsi/graphite/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/graphite-${COMMIT}"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="perl test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="perl? ( dev-lang/perl:= )"
-DEPEND="${RDEPEND}
- test? ( dev-libs/glib:2 )
-"
-BDEPEND="
- perl? (
- dev-lang/perl
- dev-perl/Locale-Maketext-Lexicon
- dev-perl/Module-Build
- )
- test? (
- ${PYTHON_DEPS}
- $(python_gen_any_dep 'dev-python/fonttools[${PYTHON_USEDEP}]')
- media-libs/fontconfig
- perl? ( virtual/perl-Test-Simple )
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.3.5-includes-libs-perl.patch"
- "${FILESDIR}/${PN}-1.35-fix-gcc-linking.patch"
- "${FILESDIR}/${PN}-1.3.14-fix-cmake-files-libdir.patch"
- "${FILESDIR}/${PN}-1.3.14-no-libtool-file.patch"
-)
-
-pkg_setup() {
- use perl && perl_set_version
- use test && python-any-r1_pkg_setup
-}
-
-python_check_deps() {
- has_version -b "dev-python/fonttools[${PYTHON_USEDEP}]"
-}
-
-src_prepare() {
- cmake_src_prepare
- use test || cmake_comment_add_subdirectory tests
-}
-
-multilib_src_configure() {
- local mycmakeargs=(
- # Renamed VM_MACHINE_TYPE to GRAPHITE2_VM_TYPE
- -DGRAPHITE2_VM_TYPE=direct
- )
- # https://sourceforge.net/p/silgraphite/bugs/49/
- [[ ${CHOST} == powerpc*-apple* ]] && mycmakeargs+=(
- -DGRAPHITE2_NSEGCACHE:BOOL=ON
- )
-
- if use elibc_musl ; then
- # bug #829690
- if use ppc || use x86 ; then
- sed -e 's:${GRAPHITE_LINK_FLAGS}:-lssp_nonshared &:' \
- -i "${S}"/src/CMakeLists.txt || die
- fi
- fi
-
- cmake_src_configure
-
- # fix perl linking
- if multilib_is_native_abi && use perl; then
- # we rely on the fact that cmake_src_configure sets BUILD_DIR
- sed -e "s:@BUILD_DIR@:\"${BUILD_DIR}/src\":" \
- -i "${S}"/contrib/perl/Build.PL || die
- fi
-}
-
-src_compile() {
- cmake-multilib_src_compile
- if use perl; then
- cd contrib/perl || die
- perl-module_src_configure
- perl-module_src_compile
- fi
-}
-
-multilib_src_test() {
- if multilib_is_native_abi; then
- cmake_src_test
- else
- einfo "Cannot test since python is not multilib."
- fi
-}
-
-src_test() {
- cmake-multilib_src_test
- if use perl; then
- # Perl tests fail due to missing POD coverage...
- perl_rm_files "contrib/perl/t/pod.t" "contrib/perl/t/pod-coverage.t"
- cd contrib/perl || die
- perl-module_src_test
- fi
-}
-
-src_install() {
- cmake-multilib_src_install
- if use perl; then
- cd contrib/perl || die
- perl-module_src_install
- perl_delete_localpod
- fi
-}