summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/ipdb/ipdb-0.13.9-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/ipdb/ipdb-0.13.9-r1.ebuild b/dev-python/ipdb/ipdb-0.13.9-r1.ebuild
new file mode 100644
index 000000000000..de8bc495eced
--- /dev/null
+++ b/dev-python/ipdb/ipdb-0.13.9-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="IPython-enabled pdb"
+HOMEPAGE="https://pypi.org/project/ipdb/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND=">=dev-python/ipython-7.17[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+DOCS=( HISTORY.txt )
+
+distutils_enable_tests unittest