summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-themes/obsidian-xcursors/obsidian-xcursors-1.0-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-themes/obsidian-xcursors/obsidian-xcursors-1.0-r1.ebuild b/x11-themes/obsidian-xcursors/obsidian-xcursors-1.0-r1.ebuild
new file mode 100644
index 000000000000..b45f0120275f
--- /dev/null
+++ b/x11-themes/obsidian-xcursors/obsidian-xcursors-1.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="Obsidian"
+
+DESCRIPTION="A shiny and clean xcursor theme"
+HOMEPAGE="https://store.kde.org/p/999984/"
+SRC_URI="mirror://gentoo/73135-${MY_PN}.tar.bz2"
+S="${WORKDIR}/${MY_PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc x86"
+
+RDEPEND="x11-libs/libXcursor"
+
+src_install() {
+ insinto /usr/share/cursors/xorg-x11/Obsidian
+ doins -r cursors
+}
+
+pkg_postinst() {
+ elog "To use this set of cursors, edit or create the file ~/.Xdefaults"
+ elog "and add the following line:"
+ elog "Xcursor.theme: ${MY_PN}"
+ elog
+ elog "You can change the size by adding a line like:"
+ elog "Xcursor.size: 48"
+ elog
+ elog "Also, to globally use this set of mouse cursors edit the file:"
+ elog " ${EROOT}/usr/share/cursors/xorg-x11/default/index.theme"
+ elog "and change the line:"
+ elog " Inherits=[current setting]"
+ elog "to"
+ elog " Inherits=${MY_PN}"
+ elog
+ elog "Note this will be overruled by a user's ~/.Xdefaults file."
+ elog
+
+ ewarn "If you experience flickering, try setting the following line in"
+ ewarn "the Device section of your xorg.conf file:"
+ ewarn " Option \"HWCursor\" \"false\""
+}