summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/scponly/files/scponly-4.8-gcc4.4.0.patch6
-rw-r--r--net-misc/scponly/scponly-4.8-r6.ebuild (renamed from net-misc/scponly/scponly-4.8-r5.ebuild)23
2 files changed, 16 insertions, 13 deletions
diff --git a/net-misc/scponly/files/scponly-4.8-gcc4.4.0.patch b/net-misc/scponly/files/scponly-4.8-gcc4.4.0.patch
index d08ce28b93b5..8bb689f5914d 100644
--- a/net-misc/scponly/files/scponly-4.8-gcc4.4.0.patch
+++ b/net-misc/scponly/files/scponly-4.8-gcc4.4.0.patch
@@ -1,5 +1,7 @@
---- helper.c.orig 2009-05-11 00:33:08.000000000 -0600
-+++ helper.c 2009-05-11 00:39:59.000000000 -0600
+https://bugs.gentoo.org/269242
+
+--- scponly-4.8.orig/helper.c
++++ scponly-4.8/helper.c
@@ -259,11 +259,11 @@
PROG_RSYNC, logstamp());
return 1;
diff --git a/net-misc/scponly/scponly-4.8-r5.ebuild b/net-misc/scponly/scponly-4.8-r6.ebuild
index 2e53a29f0870..b3068376ead5 100644
--- a/net-misc/scponly/scponly-4.8-r5.ebuild
+++ b/net-misc/scponly/scponly-4.8-r6.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils multilib readme.gentoo toolchain-funcs user
+EAPI=7
+
+inherit multilib readme.gentoo-r1 toolchain-funcs user
DESCRIPTION="A tiny pseudoshell which only permits scp and sftp"
HOMEPAGE="https://github.com/scponly/scponly"
@@ -22,6 +23,7 @@ RDEPEND="
quota? ( sys-fs/quota )
rsync? ( net-misc/rsync )
subversion? ( dev-vcs/subversion )
+ unison? ( net-misc/unison:= )
"
DEPEND="${RDEPEND}"
@@ -29,6 +31,11 @@ myuser="scponly"
myhome="/home/${myuser}"
mysubdir="/pub"
+PATCHES=(
+ "${FILESDIR}/${P}-rsync.patch"
+ "${FILESDIR}/${P}-gcc4.4.0.patch"
+)
+
DOC_CONTENTS="
You might want to run\n
emerge --config =${CATEGORY}/${PF}\n
@@ -37,12 +44,6 @@ DOC_CONTENTS="
the SECURITY file.
"
-src_prepare() {
- epatch "${FILESDIR}/${P}-rsync.patch"
- # bug #269242
- epatch "${FILESDIR}/${P}-gcc4.4.0.patch"
-}
-
src_configure() {
CFLAGS="${CFLAGS} ${LDFLAGS}" econf \
--with-sftp-server="/usr/$(get_libdir)/misc/sftp-server" \
@@ -126,7 +127,7 @@ pkg_config() {
# passwd compatibility
if has_version "=${CATEGORY}/${PF}[passwd]" ; then
- BINARIES="${BINARIES} /bin/passwd"
+ BINARIES="${BINARIES} /usr/bin/passwd"
fi
# quota compatibility
@@ -197,7 +198,7 @@ pkg_config() {
for BIN in ${BINARIES}; do
einfo "Install ${BIN}"
install -o0 -g0 -m0755 -d "${myhome}$(dirname ${BIN})"
- if [ "${BIN}" = "/bin/passwd" ]; then # needs suid
+ if [ "${BIN}" = "/usr/bin/passwd" ]; then # needs suid
install -p -o0 -g0 -m04711 "${BIN}" "${myhome}/${BIN}"
else
install -p -o0 -g0 -m0755 "${BIN}" "${myhome}/${BIN}"