summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/ppcoind/files/ppcoind-0.4.0-gcc6.patch11
-rw-r--r--net-p2p/ppcoind/ppcoind-0.4.0.ebuild4
2 files changed, 14 insertions, 1 deletions
diff --git a/net-p2p/ppcoind/files/ppcoind-0.4.0-gcc6.patch b/net-p2p/ppcoind/files/ppcoind-0.4.0-gcc6.patch
new file mode 100644
index 000000000000..76bad3feb5a4
--- /dev/null
+++ b/net-p2p/ppcoind/files/ppcoind-0.4.0-gcc6.patch
@@ -0,0 +1,11 @@
+--- a/src/net.cpp
++++ b/src/net.cpp
+@@ -51,7 +51,7 @@ CAddress addrLocalHost(CService("0.0.0.0", 0), nLocalServices);
+ CAddress addrSeenByPeer(CService("0.0.0.0", 0), nLocalServices);
+ static CNode* pnodeLocalHost = NULL;
+ uint64 nLocalHostNonce = 0;
+-array<int, THREAD_MAX> vnThreadsRunning;
++boost::array<int, THREAD_MAX> vnThreadsRunning;
+ static SOCKET hListenSocket = INVALID_SOCKET;
+ CAddrMan addrman;
+
diff --git a/net-p2p/ppcoind/ppcoind-0.4.0.ebuild b/net-p2p/ppcoind/ppcoind-0.4.0.ebuild
index 96a1e4377fc3..f0cc1712c908 100644
--- a/net-p2p/ppcoind/ppcoind-0.4.0.ebuild
+++ b/net-p2p/ppcoind/ppcoind-0.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -45,6 +45,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc6.patch
+
if has_version '>=dev-libs/boost-1.52'; then
sed -i 's/\(-l db_cxx\)/-l boost_chrono$(BOOST_LIB_SUFFIX) \1/' src/makefile.unix
fi