summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/colpack/Manifest1
-rw-r--r--sci-libs/colpack/colpack-1.0.10.ebuild48
-rw-r--r--sci-libs/colpack/metadata.xml11
3 files changed, 56 insertions, 4 deletions
diff --git a/sci-libs/colpack/Manifest b/sci-libs/colpack/Manifest
index f78f4a87ff71..f28958b88068 100644
--- a/sci-libs/colpack/Manifest
+++ b/sci-libs/colpack/Manifest
@@ -1,2 +1,3 @@
DIST ColPack-1.0.6.tar.gz 1027189 SHA256 d03208883aaa48544124c7fa950c2ea1aa88bc38c7997c4a563b176b6bc212ea SHA512 646ffdd459c40906f6c57888c0e38b791f9559a88ce649e9041271655a9d98658db1c6c0f3b09d64b9bd2c7d74c71a6bd8b13972ae7c7bbac42b300b8e3844c9 WHIRLPOOL 80e5c7f368b362bf4dda84661b364fa1f55215446339fec98bce5dfd7a7dcffc97a79c73329d0a721f012c7bc6651626f6ed5b1f5e284c1b540bcf047d0178b7
DIST ColPack-1.0.9.tar.gz 1185335 SHA256 06c5d3e61ab873b27d7962a9f09e90cbc52ccd9f480e88f1ecb50e6bced11932 SHA512 762ab506f95788f9134033b60bf582472b80ab14766ad6795a7db1b780de0ae49bb30f1c9bd74b4f62cf46cc6029c37ef90a483e41b62bf4067cd4a71eb3db6c WHIRLPOOL f84e1766350265c3ecfb43d827327a018218be342f22adbd5f95d7172b9b489c12ed3978796b9c9d70b69058d88816ed6cb5979217ccca16c7691ecccedc3a51
+DIST colpack-1.0.10.tar.gz 658087 SHA256 b22ead7da80fa1735291b2d83198adf41bf36101e4fcb2c4f07c1cfacf211c75 SHA512 566b7906c5d0dbcd6dcb9c359510ee8b13bf3249e56d8f88f7806493d1df14f54638a0558d601ab4dbc28f36093795eede57a059a7c4e66438b47bf5a0119808 WHIRLPOOL c416c981aff798c6f0c9c33cf24f93fc0ab498e965159070697bc9eadb0014d9f6729858c7113811eec10e4219867075ef11191f6ca214320f83ccb2bf5bf625
diff --git a/sci-libs/colpack/colpack-1.0.10.ebuild b/sci-libs/colpack/colpack-1.0.10.ebuild
new file mode 100644
index 000000000000..6469493e7fa4
--- /dev/null
+++ b/sci-libs/colpack/colpack-1.0.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils
+
+MYPN="ColPack"
+
+DESCRIPTION="C++ algorithms for specialized vertex coloring problems"
+LICENSE="GPL-3 LGPL-3"
+HOMEPAGE="http://cscapes.cs.purdue.edu/coloringpage/"
+SRC_URI="https://github.com/CSCsw/${MYPN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+IUSE="openmp static-libs"
+KEYWORDS="~alpha ~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYPN}-${PV}"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp; then
+ ewarn "You are using gcc without OpenMP"
+ die "Need an OpenMP capable compiler"
+ fi
+}
+
+src_prepare() {
+ default
+ sed -e 's/-O3//' -i Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable openmp)
+}
+
+src_install() {
+ default
+ rm -rf "${ED}"/usr/examples
+ use static-libs || prune_libtool_files --all
+}
diff --git a/sci-libs/colpack/metadata.xml b/sci-libs/colpack/metadata.xml
index 174f7cf0ae9e..c9aa068b01c3 100644
--- a/sci-libs/colpack/metadata.xml
+++ b/sci-libs/colpack/metadata.xml
@@ -6,8 +6,11 @@
<name>Gentoo Science Project</name>
</maintainer>
<longdescription lang="en">
- ColPack is a package comprising of implementations of algorithms for
- the specialized vertex coloring problems as well as algorithms for a
- variety of related supporting tasks in derivative computation.
-</longdescription>
+ ColPack is a package comprising of implementations of algorithms for
+ the specialized vertex coloring problems as well as algorithms for a
+ variety of related supporting tasks in derivative computation.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">CSCsw/ColPack</remote-id>
+ </upstream>
</pkgmetadata>