summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyuv/Manifest1
-rw-r--r--dev-python/pyuv/metadata.xml44
-rw-r--r--dev-python/pyuv/pyuv-1.2.0.ebuild29
3 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/pyuv/Manifest b/dev-python/pyuv/Manifest
new file mode 100644
index 000000000000..33e2d1b2530a
--- /dev/null
+++ b/dev-python/pyuv/Manifest
@@ -0,0 +1 @@
+DIST pyuv-1.2.0.tar.gz 98578 SHA256 9df91c86519574f65e4465884db20565d4ad4287cd6cd651ee0137430b0dd4a7 SHA512 10a8448700c609b6e9844c6bc9bd6428920a455c94bee79569006f783c7f5d2683abe46c4692d0f0016a621d0c6d0ef2decc42a9f0418e1242b79ab0f06ee9f2 WHIRLPOOL 11989f713ba205ff0fa5b76dd742a7c3eb66b00fb6c97e0a0a5aa2e2b3c041a1d35b2bfd950a54fb0a7adb9ae1c5753c97ee4c6278518e46a345a462827835eb
diff --git a/dev-python/pyuv/metadata.xml b/dev-python/pyuv/metadata.xml
new file mode 100644
index 000000000000..bd1f47aa9d38
--- /dev/null
+++ b/dev-python/pyuv/metadata.xml
@@ -0,0 +1,44 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hasufell@gentoo.org</email>
+ <name>Julian Ospald</name>
+ </maintainer>
+ <longdescription lang="en">
+ pyuv is a Python module which provides an interface to
+ <pkg>dev-libs/libuv</pkg>.
+ libuv is a high performance asynchronous networking and platform
+ abstraction library.
+
+ libuv is built on top of epoll/kequeue/event ports/etc on Unix and
+ IOCP on Windows systems providing a consistent API on top of them.
+
+ pyuv's features:
+ * Non-blocking TCP sockets
+ * Non-blocking named pipes
+ * UDP support (including multicast)
+ * Timers
+ * Child process spawning
+ * Asynchronous DNS resolution (getaddrinfo)
+ * Asynchronous file system APIs
+ * High resolution time
+ * System memory information
+ * System CPUs information
+ * Network interfaces information
+ * Thread pool scheduling
+ * ANSI escape code controlled TTY
+ * File system events (inotify style and stat based)
+ * IPC and TCP socket sharing between processes
+ * Arbitrary file descriptor polling
+ * Thread synchronization primitives
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <email>saghul@gmail.com</email>
+ <name>Saúl Ibarra Corretgé</name>
+ </maintainer>
+ <remote-id type="github">saghul/pyuv</remote-id>
+ <remote-id type="pypi">pyuv</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyuv/pyuv-1.2.0.ebuild b/dev-python/pyuv/pyuv-1.2.0.ebuild
new file mode 100644
index 000000000000..ab665cacadd1
--- /dev/null
+++ b/dev-python/pyuv/pyuv-1.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for libuv"
+HOMEPAGE="https://pyuv.readthedocs.org/en"
+SRC_URI="https://github.com/saghul/pyuv/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# https://github.com/saghul/pyuv/blob/v1.x/setup_libuv.py#L117
+RDEPEND=">=dev-libs/libuv-1.7.3:0/1"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/pyuv-pyuv-${PV}"
+
+src_configure() {
+ mydistutilsargs=( build_ext --use-system-libuv )
+ distutils-r1_src_configure
+}