summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/ffmpeg/ffmpeg-4.3.ebuild5
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/media-video/ffmpeg/ffmpeg-4.3.ebuild b/media-video/ffmpeg/ffmpeg-4.3.ebuild
index 9c9b6d816bad..c0ff83aacf25 100644
--- a/media-video/ffmpeg/ffmpeg-4.3.ebuild
+++ b/media-video/ffmpeg/ffmpeg-4.3.ebuild
@@ -345,7 +345,7 @@ src_prepare() {
}
multilib_src_configure() {
- local myconf=( ${EXTRA_FFMPEG_CONF} )
+ local myconf=( )
local ffuse=( "${FFMPEG_FLAG_MAP[@]}" )
use openssl || use libressl && use gpl && myconf+=( --enable-nonfree )
@@ -475,7 +475,8 @@ multilib_src_configure() {
--ranlib="$(tc-getRANLIB)" \
--optflags="${CFLAGS}" \
$(use_enable static-libs static) \
- "${myconf[@]}"
+ "${myconf[@]}" \
+ ${EXTRA_FFMPEG_CONF}
echo "${@}"
"${@}" || die
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 1492176f8a9b..ab35ad930eee 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -344,7 +344,7 @@ src_prepare() {
}
multilib_src_configure() {
- local myconf=( ${EXTRA_FFMPEG_CONF} )
+ local myconf=( )
local ffuse=( "${FFMPEG_FLAG_MAP[@]}" )
use openssl || use libressl && use gpl && myconf+=( --enable-nonfree )
@@ -474,7 +474,8 @@ multilib_src_configure() {
--ranlib="$(tc-getRANLIB)" \
--optflags="${CFLAGS}" \
$(use_enable static-libs static) \
- "${myconf[@]}"
+ "${myconf[@]}" \
+ ${EXTRA_FFMPEG_CONF}
echo "${@}"
"${@}" || die