summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-puzzle/biniax2/biniax2-1.30-r1.ebuild42
-rw-r--r--games-puzzle/biniax2/files/biniax2-1.30-build.patch4
-rw-r--r--games-puzzle/biniax2/files/biniax2-1.30-dotfiles.patch16
3 files changed, 52 insertions, 10 deletions
diff --git a/games-puzzle/biniax2/biniax2-1.30-r1.ebuild b/games-puzzle/biniax2/biniax2-1.30-r1.ebuild
new file mode 100644
index 000000000000..e4710407e8e7
--- /dev/null
+++ b/games-puzzle/biniax2/biniax2-1.30-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="Logic game with arcade and tactics modes"
+HOMEPAGE="http://biniax.com/"
+SRC_URI="http://mordred.dir.bg/biniax/${P}-fullsrc.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mod]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ rm -f data/Thumbs.db
+ sed -i \
+ -e "s:data/:/usr/share/${PN}/:" \
+ desktop/{gfx,snd}.c \
+ || die
+ eapply \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-dotfiles.patch
+}
+
+src_install() {
+ dobin ${PN}
+ insinto "/usr/share/${PN}"
+ doins -r data/*
+ doicon "${FILESDIR}"/${PN}.xpm
+ make_desktop_entry ${PN} Biniax-2
+}
diff --git a/games-puzzle/biniax2/files/biniax2-1.30-build.patch b/games-puzzle/biniax2/files/biniax2-1.30-build.patch
index 26c053c2e98e..cce8abe91a93 100644
--- a/games-puzzle/biniax2/files/biniax2-1.30-build.patch
+++ b/games-puzzle/biniax2/files/biniax2-1.30-build.patch
@@ -1,5 +1,5 @@
---- makefile
-+++ makefile
+--- a/makefile
++++ b/makefile
@@ -4,7 +4,7 @@
# To execute the game you need the runtimes of SDL, SDL_mixer and SDL_image.
diff --git a/games-puzzle/biniax2/files/biniax2-1.30-dotfiles.patch b/games-puzzle/biniax2/files/biniax2-1.30-dotfiles.patch
index 2cd212d6857c..00391677ce8a 100644
--- a/games-puzzle/biniax2/files/biniax2-1.30-dotfiles.patch
+++ b/games-puzzle/biniax2/files/biniax2-1.30-dotfiles.patch
@@ -1,5 +1,5 @@
---- biniax.c
-+++ biniax.c
+--- a/biniax.c
++++ b/biniax.c
@@ -47,6 +47,8 @@
INCLUDES
******************************************************************************/
@@ -18,8 +18,8 @@
cfgInit();
hofInit();
if ( gfxInit() == BNX_FALSE )
---- desktop/cfg.c
-+++ desktop/cfg.c
+--- a/desktop/cfg.c
++++ b/desktop/cfg.c
@@ -36,7 +36,7 @@
******************************************************************************/
@@ -29,8 +29,8 @@
struct BNX_SETUP
{
---- game.h
-+++ game.h
+--- a/game.h
++++ b/game.h
@@ -37,7 +37,7 @@
DEFINITIONS
******************************************************************************/
@@ -40,8 +40,8 @@
/******************************************************************************
CONSTANTS
---- hof.c
-+++ hof.c
+--- a/hof.c
++++ b/hof.c
@@ -34,7 +34,7 @@
#define chCursor '_' /* Cursor ON */
#define chSpace ' ' /* Cursor OFF*/