summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/webstorm/webstorm-2017.2.4.172.4155.35.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-util/webstorm/webstorm-2017.2.4.172.4155.35.ebuild b/dev-util/webstorm/webstorm-2017.2.4.172.4155.35.ebuild
index e5e229b61de7..cd605cc309aa 100644
--- a/dev-util/webstorm/webstorm-2017.2.4.172.4155.35.ebuild
+++ b/dev-util/webstorm/webstorm-2017.2.4.172.4155.35.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-
EAPI=6
+
inherit eutils versionator
DESCRIPTION="JavaScript IDE for client- and server-side development with Node.js"
@@ -14,6 +14,7 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND=">=virtual/jdk-1.7"
+
S="${WORKDIR}/WebStorm-$(get_version_component_range 4-6)"
src_install() {
@@ -24,4 +25,4 @@ src_install() {
make_wrapper "${PN}" "/opt/${PN}/bin/${PN}.sh"
newicon "bin/${PN}.svg" "${PN}.svg"
make_desktop_entry "${PN}" "${PN}" "${PN}" "Development;IDE;"
-} \ No newline at end of file
+}