summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'acct-user/znc/znc-0-r3.ebuild')
-rw-r--r--acct-user/znc/znc-0-r3.ebuild16
1 files changed, 16 insertions, 0 deletions
diff --git a/acct-user/znc/znc-0-r3.ebuild b/acct-user/znc/znc-0-r3.ebuild
new file mode 100644
index 000000000000..045ff97ee989
--- /dev/null
+++ b/acct-user/znc/znc-0-r3.ebuild
@@ -0,0 +1,16 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit acct-user
+
+DESCRIPTION="User for net-irc/znc"
+ACCT_USER_ID=421
+ACCT_USER_GROUPS=( ${PN} )
+# The systemd unit needs HOME to be set
+# https://bugs.gentoo.org/521916
+ACCT_USER_HOME=/var/lib/znc
+ACCT_USER_HOME_PERMS=0700
+
+acct-user_add_deps