summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/epos/epos-2.5.37-r3.ebuild')
-rw-r--r--app-accessibility/epos/epos-2.5.37-r3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-accessibility/epos/epos-2.5.37-r3.ebuild b/app-accessibility/epos/epos-2.5.37-r3.ebuild
new file mode 100644
index 000000000000..f4146ed522d7
--- /dev/null
+++ b/app-accessibility/epos/epos-2.5.37-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="language independent text-to-speech system"
+HOMEPAGE="http://epos.ufe.cz/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~hppa ~ia64 ppc ppc64 x86"
+IUSE=""
+
+DEPEND="dev-util/byacc"
+RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.5.37-gcc43.patch
+ "${FILESDIR}"/${PN}-2.5.37-gcc45.patch
+ "${FILESDIR}"/${PN}-2.5.37-gcc47.patch
+ "${FILESDIR}"/${PN}-2.5.37-disable-tests.patch
+ "${FILESDIR}"/${PN}-2.5.37-gcc7.patch
+)
+
+src_prepare() {
+ default
+ sed -i -e "s/CCC/#CCC/" configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-charsets \
+ --disable-portaudio \
+ YACC=byacc
+}
+
+src_install() {
+ default
+
+ doinitd "${FILESDIR}/eposd"
+ dodoc WELCOME THANKS Changes "${FILESDIR}/README.gentoo"
+}