summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/nfbtrans/nfbtrans-7.74-r2.ebuild')
-rw-r--r--app-accessibility/nfbtrans/nfbtrans-7.74-r2.ebuild36
1 files changed, 19 insertions, 17 deletions
diff --git a/app-accessibility/nfbtrans/nfbtrans-7.74-r2.ebuild b/app-accessibility/nfbtrans/nfbtrans-7.74-r2.ebuild
index c458fcee9dcd..8559b3ff195b 100644
--- a/app-accessibility/nfbtrans/nfbtrans-7.74-r2.ebuild
+++ b/app-accessibility/nfbtrans/nfbtrans-7.74-r2.ebuild
@@ -1,41 +1,43 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
-DESCRIPTION="braille translator from the National Federation of the Blind"
-HOMEPAGE="http://www.nfb.org/nfbtrans"
-SRC_URI="http://www.nfb.org/Images/nfb/Products_Technology/nfbtr774.zip"
+DESCRIPTION="Braille translator from the National Federation of the Blind"
+HOMEPAGE="http://www.nfbnet.org/download/nfbtrans.htm"
+SRC_URI="http://www.nfb.org/Images/nfb/Products_Technology/nfbtr$(ver_rs 1-2 '').zip"
+S="${WORKDIR}"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
-DEPEND=" >=app-arch/unzip-5.50-r2"
-RDEPEND=""
-
-S=${WORKDIR}
+BDEPEND=" >=app-arch/unzip-5.50-r2"
PATCHES=(
-"${FILESDIR}"/${P}-gentoo-fix.patch
-"${FILESDIR}"/${P}-getline-fix.patch
-"${FILESDIR}"/${P}-respect-ldflags.patch
+ "${FILESDIR}"/${P}-gentoo-fix.patch
+ "${FILESDIR}"/${P}-getline-fix.patch
+ "${FILESDIR}"/${P}-respect-ldflags.patch
)
src_prepare() {
mv MAKEFILE Makefile || die
mv SPANISH.ZIP spanish.zip || die
- emake lowercase
+
default
+
+ emake lowercase
}
src_compile() {
- emake CC=$(tc-getCC) \
+ emake \
+ CC="$(tc-getCC)" \
LIBS= \
- CFLAGS="${CFLAGS} -DLINUX" LDFLAGS="${LDFLAGS}" all
+ CFLAGS="${CFLAGS} -DLINUX" \
+ LDFLAGS="${LDFLAGS}" \
+ all
}
src_install() {