summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/analog')
-rw-r--r--app-admin/analog/Manifest1
-rw-r--r--app-admin/analog/analog-6.0-r4.ebuild56
-rw-r--r--app-admin/analog/files/analog-5.1-gentoo.diff20
-rw-r--r--app-admin/analog/files/analog-6.0-bzip2.patch64
-rw-r--r--app-admin/analog/files/analog-6.0-undefined-macro.patch38
-rw-r--r--app-admin/analog/files/analog.cfg101
-rw-r--r--app-admin/analog/metadata.xml8
7 files changed, 288 insertions, 0 deletions
diff --git a/app-admin/analog/Manifest b/app-admin/analog/Manifest
new file mode 100644
index 000000000000..173efca8b0ac
--- /dev/null
+++ b/app-admin/analog/Manifest
@@ -0,0 +1 @@
+DIST analog-6.0.tar.gz 1553316 SHA256 31c0e2bedd0968f9d4657db233b20427d8c497be98194daf19d6f859d7f6fcca SHA512 42b766d45f86a32d2e97cc2be35ebb5f4e0ffc2fb72d48196939027ea1ed3398a8cc0a43c47868f542bfb464199ab35bd93fa2ba5e37c4fc83ff15cfe19b9c60 WHIRLPOOL fd5b2685cf443a3336904973cfd2985a2393a5d021b06708d23ac717f6e4f53310942923ae3e41c69640d22b435e6bd0d44647502ec50af7b0517f9f48aa14cb
diff --git a/app-admin/analog/analog-6.0-r4.ebuild b/app-admin/analog/analog-6.0-r4.ebuild
new file mode 100644
index 000000000000..344dd3829a6f
--- /dev/null
+++ b/app-admin/analog/analog-6.0-r4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A webserver log analyzer"
+HOMEPAGE="http://www.analog.cx/"
+SRC_URI="http://www.analog.cx/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND=">=dev-libs/libpcre-3.4
+ >=media-libs/gd-1.8.4-r2[jpeg,png]
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cd src/
+ epatch "${FILESDIR}/${PN}-5.1-gentoo.diff"
+ epatch "${FILESDIR}/${P}-bzip2.patch"
+ epatch "${FILESDIR}/${P}-undefined-macro.patch"
+
+ sed -i Makefile \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ || die "sed Makefile"
+}
+
+src_compile() {
+ tc-export CC
+ # emake in main dir just executes "cd src && make",
+ # i.e. MAKEOPTS are ignored
+ emake -C src
+}
+
+src_install() {
+ dobin analog
+ newman analog.man analog.1
+
+ dodoc README.txt Licence.txt analog.cfg
+ dohtml -a html,gif,css,ico docs/*
+ dohtml -r how-to
+ dodoc -r examples
+ docinto cgi ; dodoc anlgform.pl
+
+ insinto /usr/share/analog/images ; doins images/*
+ insinto /usr/share/analog/lang ; doins lang/*
+ dodir /var/log/analog
+ dosym /usr/share/analog/images /var/log/analog/images
+ insinto /etc/analog ; doins "${FILESDIR}/analog.cfg"
+}
diff --git a/app-admin/analog/files/analog-5.1-gentoo.diff b/app-admin/analog/files/analog-5.1-gentoo.diff
new file mode 100644
index 000000000000..b604c254c572
--- /dev/null
+++ b/app-admin/analog/files/analog-5.1-gentoo.diff
@@ -0,0 +1,20 @@
+--- a/src/anlghead.h Wed Nov 7 06:06:46 2001
++++ b/src/anlghead.h Mon Dec 31 16:47:43 2001
+@@ -81,15 +81,11 @@
+ and use that directory; or the current directory if it couldn't deduce a
+ directory. This may or may not work, so it's better to specify a location
+ explicitly here if you know where the files will be kept. */
+-#ifndef LANGDIR
+-#define LANGDIR NULL
+-#endif
++#define LANGDIR "/usr/share/analog/lang/"
+ /* Directory where the language files live. Actually, if this one is defined
+ to be NULL, they will be looked for inside the "lang" subdirectory of the
+ directory containing the analog binary. */
+-#ifndef CONFIGDIR
+-#define CONFIGDIR NULL
+-#endif
++#define CONFIGDIR "/etc/analog/"
+ /* Directory containing configuration files. */
+ #ifndef LOGSDIR
+ #define LOGSDIR NULL
diff --git a/app-admin/analog/files/analog-6.0-bzip2.patch b/app-admin/analog/files/analog-6.0-bzip2.patch
new file mode 100644
index 000000000000..f950a30ef470
--- /dev/null
+++ b/app-admin/analog/files/analog-6.0-bzip2.patch
@@ -0,0 +1,64 @@
+Use system bzip2 library. Get CC and CFLAGS from environment.
+ -jer (bug #249140)
+
+
+--- a/src/Makefile 2004-12-19 14:51:30.000000000 +0100
++++ b/src/Makefile 2008-12-15 22:50:04.000000000 +0100
+@@ -2,16 +2,16 @@
+ # Please read docs/Readme.html, or http://www.analog.cx/
+ # This is a general Unix-like Makefile: Makefiles for other OS's can be found
+ # in the "build" directory.
+-CC = gcc # which compiler to use: eg cc, acc, gcc. NB Different
++# CC is set in the environment.
+ # compilers need different CFLAGS, e.g., -O instead of -O2.
+ MAKE = make # which "make" to use
+-CFLAGS = -O2 # options, e.g. for optimisation or ANSI compilation.
++# CFLAGS is set in the environment.
+ # Some OS's need -D_FILE_OFFSET_BITS=64 to support files > 2MB.
+ # HP/UX cc needs CFLAGS = -Aa (HP/UX 9) or -Ae (HP/UX 10)
+ # BeOS needs CFLAGS = -O2 -Wl,-L/boot/home/config/lib
+ # BS2000/OSD needs CFLAGS = -XLLML -XLLMK
+ # NeXTSTEP needs CFLAGS = -O2 -pipe -no-precomp
+-DEFS = # any combination of -DNOPIPES -DNODNS -DNODIRENT -DNOGLOB ...
++DEFS = -DHAVE_GD -DHAVE_PCRE -DHAVE_ZLIB -DHAVE_BZLIB
+ # ... -DNOOPEN -DNOFOLLOW -DNOALARM -DNOGRAPHICS -DNOGMTIME ...
+ # ... -DEBCDIC -DUSE_PLAIN_SETJMP ...
+ # ... -DHAVE_GD -DHAVE_ZLIB -DHAVE_BZLIB -DHAVE_PCRE ...
+@@ -30,7 +30,7 @@
+ #
+ OS = UNIX # Operating system: UNIX, DOS, WIN32, MAC, OS2, OSX, VMS
+ # RISCOS, BEOS, NEXTSTEP, MPEIX, BS2000, AS400, OS390
+-LIBS = -lm # extra libraries needed; most platforms (but not OS X or BeOS)
++LIBS = -lgd -lz -lbz2 -lpcre -lm -lpng -ljpeg
+ # need -lm LAST
+ # if you defined HAVE_GD above you also need -lgd -lpng -ljpeg -lz
+ # if you defined HAVE_ZLIB above you also need -lz
+@@ -54,7 +54,7 @@
+ input.o macinput.o macstuff.o output.o output2.o outcro.o outhtml.o \
+ outlatex.o outplain.o outxhtml.o outxml.o process.o settings.o sort.o \
+ tree.o utils.o win32.o
+-SUBDIRS = bzip2 libgd libpng pcre unzip zlib
++SUBDIRS = libgd libpng pcre unzip zlib
+ SUBDIROBJS = libgd/gd.o libgd/gd_io.o libgd/gd_io_file.o libgd/gd_png.o \
+ libgd/gdfontf.o libgd/gdfonts.o libgd/gdtables.o \
+ libpng/png.o libpng/pngerror.o libpng/pngmem.o libpng/pngset.o \
+@@ -63,9 +63,7 @@
+ zlib/adler32.o zlib/compress.o zlib/crc32.o zlib/deflate.o \
+ zlib/gzio.o zlib/infblock.o zlib/infcodes.o zlib/inffast.o \
+ zlib/inflate.o zlib/inftrees.o zlib/infutil.o zlib/trees.o \
+- zlib/uncompr.o zlib/zutil.o unzip/ioapi.o unzip/unzip.o \
+- bzip2/bzlib.o bzip2/blocksort.o bzip2/compress.o bzip2/crctable.o \
+- bzip2/decompress.o bzip2/huffman.o bzip2/randtable.o
++ zlib/uncompr.o zlib/zutil.o unzip/ioapi.o unzip/unzip.o
+ HEADERS = anlghead.h anlghea2.h anlghea3.h anlghea4.h macdir.h \
+ pcre/pcre.h libgd/gd.h libgd/gdfontf.h libgd/gdfonts.h unzip/unzip.h \
+ zlib/zlib.h bzip2/bzlib.h
+@@ -77,8 +75,6 @@
+
+ # There doesn't seem to be a good way to write all these rules in a generic
+ # form that works for all "make" programs
+-bzip2: ALWAYS
+- cd bzip2 && $(MAKE) 'CC=$(CC)' 'ALLCFLAGS=$(ALLCFLAGS)'
+
+ libgd: ALWAYS
+ cd libgd && $(MAKE) 'CC=$(CC)' 'ALLCFLAGS=$(ALLCFLAGS)'
diff --git a/app-admin/analog/files/analog-6.0-undefined-macro.patch b/app-admin/analog/files/analog-6.0-undefined-macro.patch
new file mode 100644
index 000000000000..5a98541c465c
--- /dev/null
+++ b/app-admin/analog/files/analog-6.0-undefined-macro.patch
@@ -0,0 +1,38 @@
+--- a/src/unzip/ioapi.h 2004-12-19 14:51:32.000000000 +0100
++++ b/src/unzip/ioapi.h 2012-01-11 18:07:59.570768250 +0100
+@@ -35,6 +35,16 @@
+ extern "C" {
+ #endif
+
++/* Work-around for NetBSD. Its zconf.h doesn't define OF(x) */
++#ifndef OF
++#ifdef __STDC__
++#define OF(x) x
++#else
++#define OF(x) ()
++#endif
++#endif
++
++
+ typedef voidpf (ZCALLBACK *open_file_func) OF((voidpf opaque, const char* filename, int mode));
+ typedef uLong (ZCALLBACK *read_file_func) OF((voidpf opaque, voidpf stream, void* buf, uLong size));
+ typedef uLong (ZCALLBACK *write_file_func) OF((voidpf opaque, voidpf stream, const void* buf, uLong size));
+--- a/src/unzip/unzip.h 2004-12-19 14:51:32.000000000 +0100
++++ b/src/unzip/unzip.h 2012-01-11 18:00:25.988120225 +0100
+@@ -47,6 +47,15 @@
+ extern "C" {
+ #endif
+
++/* Work-around for NetBSD. Its zconf.h doesn't define OF(x) */
++#ifndef OF
++#ifdef __STDC__
++#define OF(x) x
++#else
++#define OF(x) ()
++#endif
++#endif
++
+ #ifndef _ZLIB_H
+ #include "../zlib/zlib.h"
+ #endif
+
diff --git a/app-admin/analog/files/analog.cfg b/app-admin/analog/files/analog.cfg
new file mode 100644
index 000000000000..99e452b36e3d
--- /dev/null
+++ b/app-admin/analog/files/analog.cfg
@@ -0,0 +1,101 @@
+# Configuration file for analog 5.1
+# See http://www.analog.cx/
+#
+# This is a simple default configuration file which works when you run
+# analog with no command line parameters. There are much more extensive
+# configuration examples included with the documentation.
+# See the big.cfg example file.
+#
+# If you need a LOGFORMAT command (most people don't -- try it without first!),
+# it must go here, above the LOGFILE commands.
+LOGFILE /var/log/apache/access_log
+OUTFILE /var/log/analog/index.html
+LANGUAGE ENGLISH
+IMAGEDIR images/
+# HOSTNAME "[my organisation]"
+REQLINKINCLUDE pages
+REFLINKINCLUDE *
+REDIRREFLINKINCLUDE *
+FAILREFLINKINCLUDE *
+UNCOMPRESS *.gz,*.Z "gzip -cd"
+BROWOUTPUTALIAS IWENG AOL
+SUBBROW */*
+SUBTYPE *.gz,*.Z
+# Add whichever of these types of pages you have on your server, or others.
+# PAGEINCLUDE *.shtml
+# PAGEINCLUDE *.asp
+# PAGEINCLUDE *.jsp
+# PAGEINCLUDE *.cfm
+# PAGEINCLUDE *.pl
+# PAGEINCLUDE *.php
+SEARCHENGINE http://*altavista.*/* q
+SEARCHENGINE http://*yahoo.*/* p
+SEARCHENGINE http://*google.*/* q
+SEARCHENGINE http://*lycos.*/* query
+SEARCHENGINE http://*aol.*/* query
+SEARCHENGINE http://*excite.*/* search
+SEARCHENGINE http://*go2net.*/* general
+SEARCHENGINE http://*metacrawler.*/* general
+SEARCHENGINE http://*msn.*/* MT
+SEARCHENGINE http://*hotbot.com/* MT
+SEARCHENGINE http://*netscape.*/* search
+SEARCHENGINE http://*looksmart.*/* key
+SEARCHENGINE http://*infoseek.*/* qt
+SEARCHENGINE http://*webcrawler.*/* search,searchText
+SEARCHENGINE http://*goto.*/* Keywords
+SEARCHENGINE http://*snap.*/* keyword
+SEARCHENGINE http://*dogpile.*/* q
+SEARCHENGINE http://*askjeeves.*/* ask
+SEARCHENGINE http://*ask.*/* ask
+SEARCHENGINE http://*aj.*/* ask
+SEARCHENGINE http://*directhit.*/* qry
+SEARCHENGINE http://*alltheweb.*/* query
+SEARCHENGINE http://*northernlight.*/* qr
+SEARCHENGINE http://*nlsearch.*/* qr
+SEARCHENGINE http://*dmoz.*/* search
+SEARCHENGINE http://*newhoo.*/* search
+SEARCHENGINE http://*netfind.*/* query,search,s
+SEARCHENGINE http://*/netfind* query
+SEARCHENGINE http://*/pursuit query
+ROBOTINCLUDE REGEXPI:robot
+ROBOTINCLUDE REGEXPI:spider
+ROBOTINCLUDE REGEXPI:crawler
+ROBOTINCLUDE Googlebot*
+ROBOTINCLUDE Infoseek*
+ROBOTINCLUDE Scooter*
+ROBOTINCLUDE Slurp*
+ROBOTINCLUDE Ultraseek*
+TYPEOUTPUTALIAS .html ".html [Hypertext Markup Language]"
+TYPEOUTPUTALIAS .htm ".htm [Hypertext Markup Language]"
+TYPEOUTPUTALIAS .shtml ".shtml [Server-parsed HTML]"
+TYPEOUTPUTALIAS .ps ".ps [PostScript]"
+TYPEOUTPUTALIAS .gz ".gz [Gzip compressed files]"
+TYPEOUTPUTALIAS .tar.gz ".tar.gz [Compressed archives]"
+TYPEOUTPUTALIAS .jpg ".jpg [JPEG graphics]"
+TYPEOUTPUTALIAS .jpeg ".jpeg [JPEG graphics]"
+TYPEOUTPUTALIAS .gif ".gif [GIF graphics]"
+TYPEOUTPUTALIAS .png ".png [PNG graphics]"
+TYPEOUTPUTALIAS .txt ".txt [Plain text]"
+TYPEOUTPUTALIAS .cgi ".cgi [CGI scripts]"
+TYPEOUTPUTALIAS .pl ".pl [Perl scripts]"
+TYPEOUTPUTALIAS .css ".css [Cascading Style Sheets]"
+TYPEOUTPUTALIAS .class ".class [Java class files]"
+TYPEOUTPUTALIAS .pdf ".pdf [Adobe Portable Document Format]"
+TYPEOUTPUTALIAS .zip ".zip [Zip archives]"
+TYPEOUTPUTALIAS .hqx ".hqx [Macintosh archives]"
+TYPEOUTPUTALIAS .exe ".exe [Executables]"
+TYPEOUTPUTALIAS .wav ".wav [WAV sound files]"
+TYPEOUTPUTALIAS .avi ".avi [AVI movies]"
+TYPEOUTPUTALIAS .arc ".arc [Compressed archives]"
+TYPEOUTPUTALIAS .mid ".mid [MIDI sound files]"
+TYPEOUTPUTALIAS .mp3 ".mp3 [MP3 sound files]"
+TYPEOUTPUTALIAS .doc ".doc [Microsoft Word document]"
+TYPEOUTPUTALIAS .rtf ".rtf [Rich Text Format]"
+TYPEOUTPUTALIAS .mov ".mov [Quick Time movie]"
+TYPEOUTPUTALIAS .mpg ".mpg [MPEG movie]"
+TYPEOUTPUTALIAS .mpeg ".mpeg [MPEG movie]"
+TYPEOUTPUTALIAS .asp ".asp [Active Server Pages]"
+TYPEOUTPUTALIAS .jsp ".jsp [Java Server Pages]"
+TYPEOUTPUTALIAS .cfm ".cfm [Cold Fusion]"
+TYPEOUTPUTALIAS .php ".php [PHP]"
+TYPEOUTPUTALIAS .js ".js [JavaScript code]"
diff --git a/app-admin/analog/metadata.xml b/app-admin/analog/metadata.xml
new file mode 100644
index 000000000000..f9d50da18d39
--- /dev/null
+++ b/app-admin/analog/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <description>This package lacks a primary herd or maintainer.</description>
+ </maintainer>
+</pkgmetadata>