summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/aws-elb-tools')
-rw-r--r--app-admin/aws-elb-tools/aws-elb-tools-1.0.15.1-r1.ebuild59
-rw-r--r--app-admin/aws-elb-tools/metadata.xml1
2 files changed, 60 insertions, 0 deletions
diff --git a/app-admin/aws-elb-tools/aws-elb-tools-1.0.15.1-r1.ebuild b/app-admin/aws-elb-tools/aws-elb-tools-1.0.15.1-r1.ebuild
new file mode 100644
index 000000000000..8a0234b306e9
--- /dev/null
+++ b/app-admin/aws-elb-tools/aws-elb-tools-1.0.15.1-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Serves as the client interface to the Elastic Load Balancing web service"
+HOMEPAGE="http://aws.amazon.com/developertools/Amazon-EC2/2536"
+SRC_URI="mirror://sabayon/${CATEGORY}/ElasticLoadBalancing-${PV}.zip"
+
+S="${WORKDIR}/ElasticLoadBalancing-${PV}"
+
+LICENSE="Amazon"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND="virtual/jre"
+RESTRICT="mirror"
+
+src_prepare() {
+ find . -name '*.cmd' -delete || die
+}
+
+src_install() {
+ dodir /opt/${PN}
+ insinto /opt/${PN}/lib
+ doins -r "${S}"/lib/*
+ exeinto /opt/${PN}/bin
+ doexe "${S}"/bin/*
+
+ dodir /etc/env.d
+ cat - > "${T}"/99${PN} <<EOF
+AWS_ELB_HOME=/opt/${PN}
+PATH=/opt/${PN}/bin
+ROOTPATH=/opt/${PN}/bin
+EOF
+ doenvd "${T}"/99${PN}
+
+ dodoc "THIRDPARTYLICENSE.TXT"
+}
+
+pkg_postinst() {
+ ewarn "Remember to run: env-update && source /etc/profile if you plan"
+ ewarn "to use these tools in a shell before logging out (or restarting"
+ ewarn "your login manager)"
+ elog
+ elog "You need to put the following in your ~/.bashrc replacing the"
+ elog "values with the full path to your AWS credentials file."
+ elog
+ elog " export AWS_CREDENTIAL_FILE=/path/and_filename_of_credential_file"
+ elog
+ elog "It should contains two lines: the first line lists the AWS Account's"
+ elog "AWS Access Key ID, and the second line lists the AWS Account's"
+ elog "Secret Access Key. For example:"
+ elog
+ elog " AWSAccessKeyId=AKIAIOSFODNN7EXAMPLE"
+ elog " AWSSecretKey=wJalrXUtnFEMI/K7MDENG/bPxRfiCYzEXAMPLEKEY"
+}
diff --git a/app-admin/aws-elb-tools/metadata.xml b/app-admin/aws-elb-tools/metadata.xml
index 097975e3adc2..6f49eba8f496 100644
--- a/app-admin/aws-elb-tools/metadata.xml
+++ b/app-admin/aws-elb-tools/metadata.xml
@@ -1,4 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+<!-- maintainer-needed -->
</pkgmetadata>