summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/eselect')
-rw-r--r--app-admin/eselect/Manifest4
-rw-r--r--app-admin/eselect/eselect-1.4.26-r1.ebuild (renamed from app-admin/eselect/eselect-1.4.16.ebuild)25
-rw-r--r--app-admin/eselect/eselect-1.4.27-r1.ebuild (renamed from app-admin/eselect/eselect-1.4.17.ebuild)17
-rw-r--r--app-admin/eselect/eselect-9999.ebuild10
-rw-r--r--app-admin/eselect/metadata.xml5
5 files changed, 33 insertions, 28 deletions
diff --git a/app-admin/eselect/Manifest b/app-admin/eselect/Manifest
index 3450cf5c41c7..5cd4e19cf408 100644
--- a/app-admin/eselect/Manifest
+++ b/app-admin/eselect/Manifest
@@ -1,2 +1,2 @@
-DIST eselect-1.4.16.tar.xz 178660 BLAKE2B dae97ee324cb67983c5395b5dc54c4b84d2da43f6a0c5c8ab81ff402ab211e9d1f1d3fe5c174b130ac1e11d3dd19e3812056274145415ee029e649cda880cd95 SHA512 264fb6122f5f7c9e73bb2250a94c3c0377e5263e2e5ae653ed58e08ebf6ed1b4aa165ae5c1d70b0156081c4db5672d1ec9d379782919d5b40a2f3e862378ce62
-DIST eselect-1.4.17.tar.xz 178980 BLAKE2B d905ac88bc009080912af75e64c7920d745788866fa3cb35466d68a652efbbd6984d6e1efeed76d9a344aed94705b74c85aa43e9c037d4d548d2e24afa69bd7a SHA512 35dc4c52f44c4f64db9c0dc2aec57b3055a6d36760b1bbbd094ad11b3f9e71a731444802632817b89c3b511f1dc9bb92046b59322d177e13fdc501ed767b591e
+DIST eselect-1.4.26.tar.xz 184332 BLAKE2B ee1e8890802fc50646c8d1d5219f1ab0ec5cfc0138c758f73ad6baccf673992bbf3e763d8e84491f33e724ba4e1cf3bed6971ba7fa4373e0f06464ff4a5fa1e6 SHA512 397ae2f15d90d722eb84225b08f1afaaf6f89758bfae5d93b0a1c3eddc997c21e74ab62e09ee5e71941d3a8587b3372b64336d12054c3bbf0e56e1ba398a26f9
+DIST eselect-1.4.27.tar.xz 184464 BLAKE2B 718874f4d0651194f361ca3202e5140982812bf486c8efe82354944d55206b0113fa135992203e8baa00019c3fd773a90ddaf67157c16f4ac2d69965d9822fbd SHA512 f534785fc1f79869840f420b4ab2b2bf35593c504cce878a6d3d07f75012cf32288009ea9ac2a5607dba216a794110a64c5f2c54d5d8a3c641328489cecc024b
diff --git a/app-admin/eselect/eselect-1.4.16.ebuild b/app-admin/eselect/eselect-1.4.26-r1.ebuild
index 555ce6185536..7651d332b72a 100644
--- a/app-admin/eselect/eselect-1.4.16.ebuild
+++ b/app-admin/eselect/eselect-1.4.26-r1.ebuild
@@ -1,7 +1,12 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+# Packages sharing a common release tarball:
+# app-admin/eselect
+# app-emacs/eselect-mode
+# Please bump and mark them stable together!
inherit bash-completion-r1
@@ -11,20 +16,16 @@ SRC_URI="https://dev.gentoo.org/~ulm/eselect/${P}.tar.xz"
LICENSE="GPL-2+ || ( GPL-2+ CC-BY-SA-4.0 )"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ~ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="doc emacs vim-syntax"
-RDEPEND="sys-apps/sed
- || (
- sys-apps/coreutils
- app-misc/realpath
- )"
-DEPEND="${RDEPEND}
- doc? ( dev-python/docutils )"
-RDEPEND="${RDEPEND}
+# coreutils for realpath
+DEPEND="sys-apps/coreutils
+ sys-apps/sed"
+RDEPEND="${DEPEND}
sys-apps/file
sys-libs/ncurses:0"
-
+BDEPEND="doc? ( dev-python/docutils )"
PDEPEND="emacs? ( app-emacs/eselect-mode )
vim-syntax? ( app-vim/eselect-syntax )"
diff --git a/app-admin/eselect/eselect-1.4.17.ebuild b/app-admin/eselect/eselect-1.4.27-r1.ebuild
index 40e4b07b1903..7591adecec8d 100644
--- a/app-admin/eselect/eselect-1.4.17.ebuild
+++ b/app-admin/eselect/eselect-1.4.27-r1.ebuild
@@ -1,8 +1,13 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+# Packages sharing a common release tarball:
+# app-admin/eselect
+# app-emacs/eselect-mode
+# Please bump and mark them stable together!
+
inherit bash-completion-r1
DESCRIPTION="Gentoo's multi-purpose configuration and management tool"
@@ -11,14 +16,12 @@ SRC_URI="https://dev.gentoo.org/~ulm/eselect/${P}.tar.xz"
LICENSE="GPL-2+ || ( GPL-2+ CC-BY-SA-4.0 )"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="doc emacs vim-syntax"
-DEPEND="sys-apps/sed
- || (
- sys-apps/coreutils
- app-misc/realpath
- )"
+# coreutils for realpath
+DEPEND="sys-apps/coreutils
+ sys-apps/sed"
RDEPEND="${DEPEND}
sys-apps/file
sys-libs/ncurses:0"
diff --git a/app-admin/eselect/eselect-9999.ebuild b/app-admin/eselect/eselect-9999.ebuild
index 5922f93c46e0..6c2f3d7252b2 100644
--- a/app-admin/eselect/eselect-9999.ebuild
+++ b/app-admin/eselect/eselect-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,11 +14,9 @@ LICENSE="GPL-2+ || ( GPL-2+ CC-BY-SA-4.0 )"
SLOT="0"
IUSE="doc emacs vim-syntax"
-DEPEND="sys-apps/sed
- || (
- sys-apps/coreutils
- app-misc/realpath
- )"
+# coreutils for realpath
+DEPEND="sys-apps/coreutils
+ sys-apps/sed"
RDEPEND="${DEPEND}
sys-apps/file
sys-libs/ncurses:0"
diff --git a/app-admin/eselect/metadata.xml b/app-admin/eselect/metadata.xml
index 1935b3149bde..30d66ca4bdf7 100644
--- a/app-admin/eselect/metadata.xml
+++ b/app-admin/eselect/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>eselect@gentoo.org</email>
<name>eselect configuration and management tool</name>
</maintainer>
+<upstream>
+ <remote-id type="gentoo">proj/eselect</remote-id>
+</upstream>
</pkgmetadata>