summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/fleet/fleet-0.11.5.ebuild')
-rw-r--r--app-admin/fleet/fleet-0.11.5.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-admin/fleet/fleet-0.11.5.ebuild b/app-admin/fleet/fleet-0.11.5.ebuild
new file mode 100644
index 000000000000..07d7fdd72be2
--- /dev/null
+++ b/app-admin/fleet/fleet-0.11.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGO_PN="github.com/coreos/fleet"
+
+inherit systemd vcs-snapshot
+
+DESCRIPTION="A Distributed init System"
+HOMEPAGE="https://github.com/coreos/fleet"
+SRC_URI="https://github.com/coreos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples test"
+
+DEPEND="
+ >=dev-lang/go-1.4:=
+ test? ( dev-go/go-tools )
+"
+RDEPEND=""
+
+src_compile() {
+ ./build || die 'Build failed'
+}
+
+src_test() {
+ ./test || die 'Tests failed'
+}
+
+src_install() {
+ dobin "${S}"/bin/fleetd
+ dobin "${S}"/bin/fleetctl
+
+ systemd_dounit "${FILESDIR}"/fleet.service
+ systemd_dounit "${FILESDIR}"/fleet.socket
+
+ dodoc README.md
+ use doc && dodoc -r Documentation
+ use examples && dodoc -r examples
+
+ insinto /etc/${PN}
+ newins "${PN}".conf.sample "${PN}".conf
+}