summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/hcloud')
-rw-r--r--app-admin/hcloud/Manifest3
-rw-r--r--app-admin/hcloud/hcloud-1.42.0.ebuild (renamed from app-admin/hcloud/hcloud-1.30.1.ebuild)13
-rw-r--r--app-admin/hcloud/hcloud-1.43.1.ebuild31
3 files changed, 38 insertions, 9 deletions
diff --git a/app-admin/hcloud/Manifest b/app-admin/hcloud/Manifest
index 0954e4baf25b..65239aedf187 100644
--- a/app-admin/hcloud/Manifest
+++ b/app-admin/hcloud/Manifest
@@ -1 +1,2 @@
-DIST hcloud-1.30.1.tar.xz 1688764 BLAKE2B b1044a3d9e5dd28d6010763dd2c3322e56418bd2b8b48669fd2bfb4297a0a75def85a63c08f99f0bacb78bee976438af72feae2d8d38982cfc5ce2bd3a978569 SHA512 808eb06718f1e9e3ecc6de37683cc632b822e1ef9236011fba7b72ba3cd4be238c01ae66651bae304e5118d930898635116488517ca7ec3124e4bc2f987e24e6
+DIST hcloud-1.42.0.tar.xz 1876444 BLAKE2B e7ed2e01a7c6bb106a5c46e21e26d8b6bdd7636b64c7b354674364c3db8c1776f09f199ea022e2f311e873490b737490ea22045aa00147c6066ff0a7fb96d563 SHA512 dab916666ec17b9675ba0a559170859779289c36739ac4c3d72445c87fb440df475e55e52ed628fd8d1a52421c6df4d47b0b51713e476753a66da74b3a7bf11c
+DIST hcloud-1.43.1.tar.xz 1889004 BLAKE2B 563cde962cf1fd180bbef60127b714419c09da198afeb4923f8fc1cd48850131b3b91de243de43e269497f36d14757a1e71941d30dfbee98baebb533f20e6cdd SHA512 c8fa46e9d3e2c73cc2d86e597bebf6e1dbf28b7145dbc272c403607807251ac27eee14b9ad267fdf2aa730da16ce52be4d2b0d94653612b4f375f1779c95d90b
diff --git a/app-admin/hcloud/hcloud-1.30.1.ebuild b/app-admin/hcloud/hcloud-1.42.0.ebuild
index 33ffb7d83afa..c073e3b5e053 100644
--- a/app-admin/hcloud/hcloud-1.30.1.ebuild
+++ b/app-admin/hcloud/hcloud-1.42.0.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+inherit go-module
DESCRIPTION="A command-line interface for Hetzner Cloud"
HOMEPAGE="https://github.com/hetznercloud/cli"
@@ -11,13 +13,8 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64"
-IUSE=""
-DEPEND="dev-lang/go:="
-RESTRICT="strip"
-QA_FLAGS_IGNORED=".*"
-
src_compile() {
- go build -mod vendor -o ${PN} -ldflags "-w -X github.com/hetznercloud/cli/internal/version.Version=${PV}-gentoo" ./cmd/${PN} || die "build failed"
+ ego build -o ${PN} -ldflags "-w -X github.com/hetznercloud/cli/internal/version.Version=${PV}-gentoo" ./cmd/${PN}
}
src_test() {
diff --git a/app-admin/hcloud/hcloud-1.43.1.ebuild b/app-admin/hcloud/hcloud-1.43.1.ebuild
new file mode 100644
index 000000000000..c4449b25b091
--- /dev/null
+++ b/app-admin/hcloud/hcloud-1.43.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A command-line interface for Hetzner Cloud"
+HOMEPAGE="https://github.com/hetznercloud/cli"
+SRC_URI="https://dev.gentoo.org/~ago/distfiles/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build -o ${PN} -ldflags "-w -X github.com/hetznercloud/cli/internal/version.versionPrerelease=gentoo" ./cmd/${PN}
+}
+
+src_test() {
+ # For upstream a simple test is run 'hcloud version'
+ ./hcloud version
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}