summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ide-smart/ide-smart-1.4-r3.ebuild')
-rw-r--r--app-admin/ide-smart/ide-smart-1.4-r3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-admin/ide-smart/ide-smart-1.4-r3.ebuild b/app-admin/ide-smart/ide-smart-1.4-r3.ebuild
new file mode 100644
index 000000000000..c83f7dcaf4b6
--- /dev/null
+++ b/app-admin/ide-smart/ide-smart-1.4-r3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo toolchain-funcs
+
+DESCRIPTION="A tool to read SMART information from harddiscs"
+HOMEPAGE="http://www.linalco.com/comunidad.html http://www.linux-ide.org/smart.html"
+SRC_URI="http://www.linalco.com/ragnar/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+
+src_compile() {
+ edo $(tc-getCC) ${CFLAGS} ${CPPFLAGS} -Wall ${LDFLAGS} -o ${PN} ${PN}.c
+}
+
+src_install() {
+ dobin ide-smart
+ doman ide-smart.8
+ dodoc README
+}