summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/keepass')
-rw-r--r--app-admin/keepass/Manifest6
-rw-r--r--app-admin/keepass/files/keepass-2.53-xsl-path-detection.patch22
-rw-r--r--app-admin/keepass/keepass-2.49.ebuild (renamed from app-admin/keepass/keepass-2.47.ebuild)8
-rw-r--r--app-admin/keepass/keepass-2.53.ebuild (renamed from app-admin/keepass/keepass-2.48.1.ebuild)10
-rw-r--r--app-admin/keepass/keepass-2.56.ebuild (renamed from app-admin/keepass/keepass-2.46.ebuild)13
-rw-r--r--app-admin/keepass/metadata.xml13
6 files changed, 44 insertions, 28 deletions
diff --git a/app-admin/keepass/Manifest b/app-admin/keepass/Manifest
index 4607f0f9414a..1c35ecef078a 100644
--- a/app-admin/keepass/Manifest
+++ b/app-admin/keepass/Manifest
@@ -1,3 +1,3 @@
-DIST KeePass-2.46-Source.zip 5054069 BLAKE2B 81567ab4589e53ae5cc1b75fa42cc61d9d0f390edfa8f8d860dd118a95185a8d2ca417b30b29e2b544b1d4eeeb0069fab2f0be7900fd4d7fb87d41c417b99876 SHA512 ca045cb7363092f948d72243991fe398836b13183cc2685477d7ce5dd629213b5803b4216134c7ba6451726b79ca43d1e93a1934c9cbff46293fa916b9348219
-DIST KeePass-2.47-Source.zip 5100005 BLAKE2B 9a71706efbb734244a0de6e1ba705ebaeb550368a77b1e74eaae47ec5a9c7dd12139740d7502dd5ad40e6b90e179f037ca5eae1650c2659a0a64260a93cd595f SHA512 df0f4dc9702198b4d31e78ac4fa1e85746dc7618529ab5ceaae1f6e1cc68a9a574f7892caff99e767f583fe102d87f0bfaf579f375eb227bf6f28fce6253a8f1
-DIST KeePass-2.48.1-Source.zip 5123663 BLAKE2B 919a109d114a8bc404a02f063a81013581f64e4e97fe0f024e3e0ca7a3da773a6a4af20447ab3641c3a9e82c861b8b7095793f917f0bbd69d8b443d2ce022a9f SHA512 1faa9f770fc7030f884a661d95f9d2d6d50627153fdf56331b7ad2cbaa4648e263697c999ca15e62a9946e0c6d4df45cf004ae21b715d99949967e25f4728d18
+DIST KeePass-2.49-Source.zip 5135190 BLAKE2B bf5a9aab0065a97545bd1b81a74b5ab113e4c4802873445719ce2a571745b04c69ab5d8be9a67dc59a713947f0955cbcccc782b6628f722a0d564283b943eee6 SHA512 7a25de6acb2637bd8820fb70866ab4ced4ece4b3e64172f616c2fb59d2a4e7a2f340435db10731ed3d7e66db7761487925cf1c7941b0bac12e72c5fcd9e8b7d3
+DIST KeePass-2.53-Source.zip 5201820 BLAKE2B a87918278915f1a54d8f6d6b8ef05d5a86f41a58887a1c80a8217112061fd40d59393012ae7b69d6c2110a7b0b36c57ecce4292a68e9161e99e1762b1622192e SHA512 8d35ec83ada7142e91be6a5889eabb98f1d8fe32140a3b904db76d64f42bed0ce1cc0378f38560b7f1307df545f00a398da599ef9fc44474e8c16722433d4e4e
+DIST KeePass-2.56-Source.zip 5231868 BLAKE2B d7ed0baf6db6a0398ce9bceb9a61088ef7cc14ba0c5b13a01123f9c7fca37e52bf352c438c3100ba32d59cfcfa90de790a07649684a971224bba6eb554cbed34 SHA512 cee9d8569e59a29044760dc94c4ab3ee6f1eb26aaa12d18a36d9e1b87e421291b49a3747fdb340a7af06494d65fe4d37579f16a577b0af2c053504b80e8a1c60
diff --git a/app-admin/keepass/files/keepass-2.53-xsl-path-detection.patch b/app-admin/keepass/files/keepass-2.53-xsl-path-detection.patch
new file mode 100644
index 000000000000..3fed7593a1de
--- /dev/null
+++ b/app-admin/keepass/files/keepass-2.53-xsl-path-detection.patch
@@ -0,0 +1,22 @@
+--- a/KeePass/Forms/AboutForm.cs
++++ b/KeePass/Forms/AboutForm.cs
+@@ -135,7 +135,18 @@
+ m_lvComponents.Columns.Add(strValueColumn, 100);
+
+ string strExe = WinUtil.GetExecutable();
+- string strDir = UrlUtil.GetFileDirectory(strExe, true, false);
++ string strDir = null;
++ if (KeePassLib.Native.NativeLib.IsUnix())
++ {
++ string strBPath = Environment.GetFolderPath(Environment.SpecialFolder.CommonApplicationData);
++ strBPath = UrlUtil.EnsureTerminatingSeparator(strBPath, false);
++ strBPath += PwDefs.ShortProductName.ToLower();
++ strDir = UrlUtil.EnsureTerminatingSeparator(strBPath, false);
++ }
++ else
++ {
++ strDir = UrlUtil.GetFileDirectory(strExe, true, false);
++ }
+
+ AddComponentItem(PwDefs.ShortProductName, strMainVersion, strExe);
+
diff --git a/app-admin/keepass/keepass-2.47.ebuild b/app-admin/keepass/keepass-2.49.ebuild
index afa3624b3df1..218b7363d31b 100644
--- a/app-admin/keepass/keepass-2.47.ebuild
+++ b/app-admin/keepass/keepass-2.49.ebuild
@@ -1,19 +1,19 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit desktop optfeature wrapper xdg-utils
MY_PN="KeePass"
DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
HOMEPAGE="https://keepass.info/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-Source.zip"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${MY_PN}-${PV}-Source.zip"
S="${WORKDIR}"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~arm64 x86"
IUSE="aot"
BDEPEND="app-arch/unzip"
diff --git a/app-admin/keepass/keepass-2.48.1.ebuild b/app-admin/keepass/keepass-2.53.ebuild
index afa3624b3df1..d5f8f014254f 100644
--- a/app-admin/keepass/keepass-2.48.1.ebuild
+++ b/app-admin/keepass/keepass-2.53.ebuild
@@ -1,19 +1,19 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit desktop optfeature wrapper xdg-utils
MY_PN="KeePass"
DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
HOMEPAGE="https://keepass.info/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-Source.zip"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${MY_PN}-${PV}-Source.zip"
S="${WORKDIR}"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~arm64 x86"
IUSE="aot"
BDEPEND="app-arch/unzip"
@@ -23,7 +23,7 @@ RDEPEND="
dev-dotnet/libgdiplus[cairo]
"
-PATCHES=( "${FILESDIR}/${PN}-2.36-xsl-path-detection.patch" )
+PATCHES=( "${FILESDIR}/${PN}-2.53-xsl-path-detection.patch" )
# bug #687052
# file generated by mono --aot where *FLAGS don't make sense
diff --git a/app-admin/keepass/keepass-2.46.ebuild b/app-admin/keepass/keepass-2.56.ebuild
index 550a4da96f43..6cde0c268a1d 100644
--- a/app-admin/keepass/keepass-2.46.ebuild
+++ b/app-admin/keepass/keepass-2.56.ebuild
@@ -1,19 +1,19 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit desktop optfeature wrapper xdg-utils
MY_PN="KeePass"
DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
HOMEPAGE="https://keepass.info/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-Source.zip"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${MY_PN}-${PV}-Source.zip"
S="${WORKDIR}"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="aot"
BDEPEND="app-arch/unzip"
@@ -23,7 +23,7 @@ RDEPEND="
dev-dotnet/libgdiplus[cairo]
"
-PATCHES=( "${FILESDIR}/${PN}-2.36-xsl-path-detection.patch" )
+PATCHES=( "${FILESDIR}/${PN}-2.53-xsl-path-detection.patch" )
# bug #687052
# file generated by mono --aot where *FLAGS don't make sense
@@ -46,6 +46,9 @@ src_prepare() {
src_compile() {
export MONO_REGISTRY_PATH=/dev/null # bug 659808
+ # bug 704358
+ export LANG=C LC_ALL=C
+
# Build with Release target
xbuild /target:KeePass /property:Configuration=Release || die
diff --git a/app-admin/keepass/metadata.xml b/app-admin/keepass/metadata.xml
index 59cc6e725163..390a212c5de7 100644
--- a/app-admin/keepass/metadata.xml
+++ b/app-admin/keepass/metadata.xml
@@ -1,16 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person" proxied="yes">
- <email>ale@clearmind.me</email>
- </maintainer>
- <maintainer type="person">
- <email>kensington@gentoo.org</email>
- </maintainer>
- <maintainer type="project" proxied="proxy">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
+ <!-- maintainer-needed -->
<use>
<flag name="aot">Generate native code at build time, rather than runtime.</flag>
</use>