summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/lnav/lnav-0.6.1.ebuild')
-rw-r--r--app-admin/lnav/lnav-0.6.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-admin/lnav/lnav-0.6.1.ebuild b/app-admin/lnav/lnav-0.6.1.ebuild
new file mode 100644
index 000000000000..d6f9c4c4b153
--- /dev/null
+++ b/app-admin/lnav/lnav-0.6.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="A curses-based tool for viewing and analyzing log files"
+HOMEPAGE="http://lnav.org"
+SRC_URI="https://github.com/tstack/lnav/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="unicode"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-db/sqlite:3
+ dev-libs/libpcre[cxx]
+ sys-libs/ncurses[unicode?]
+ sys-libs/readline:0
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_with unicode ncursesw)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}