summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/logsentry')
-rw-r--r--app-admin/logsentry/logsentry-1.1.1-r3.ebuild (renamed from app-admin/logsentry/logsentry-1.1.1-r2.ebuild)37
1 files changed, 20 insertions, 17 deletions
diff --git a/app-admin/logsentry/logsentry-1.1.1-r2.ebuild b/app-admin/logsentry/logsentry-1.1.1-r3.ebuild
index 7d4b1f56c3b7..8676acdc4a74 100644
--- a/app-admin/logsentry/logsentry-1.1.1-r2.ebuild
+++ b/app-admin/logsentry/logsentry-1.1.1-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
@@ -14,12 +14,15 @@ S="${WORKDIR}"/logcheck-${PV}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 arm ~mips ppc ~s390 sparc x86"
+IUSE="selinux"
-RDEPEND="virtual/mailx"
+RDEPEND="
+ virtual/mailx
+ selinux? ( sec-policy/selinux-logsentry )
+"
-src_compile() {
- einfo "compile and install mixed in the package makefile"
-}
+# compile and install mixed in the package makefile"
+src_compile() { :; }
src_install() {
dodir /usr/bin /var/tmp/logcheck /etc/logcheck
@@ -44,18 +47,18 @@ src_install() {
dodoc README* CHANGES CREDITS
dodoc systems/linux/README.*
- cat << EOF > "${S}"/logsentry.cron || die
-#!/bin/sh
-#
-# Uncomment the following if you want
-# logsentry (logcheck) to run hourly
-#
-# this is part of the logsentry package
-#
-#
+ cat <<- EOF > "${S}"/logsentry.cron || die
+ #!/bin/sh
+ #
+ # Uncomment the following if you want
+ # logsentry (logcheck) to run hourly
+ #
+ # this is part of the logsentry package
+ #
+ #
-#/bin/sh /etc/logcheck/logcheck.sh
-EOF
+ #/bin/sh /etc/logcheck/logcheck.sh
+ EOF
exeinto /etc/cron.hourly
doexe logsentry.cron