summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/mktwpol')
-rw-r--r--app-admin/mktwpol/Manifest2
-rw-r--r--app-admin/mktwpol/metadata.xml42
-rw-r--r--app-admin/mktwpol/mktwpol-0.2.4.ebuild46
-rw-r--r--app-admin/mktwpol/mktwpol-0.2.5.ebuild46
4 files changed, 136 insertions, 0 deletions
diff --git a/app-admin/mktwpol/Manifest b/app-admin/mktwpol/Manifest
new file mode 100644
index 000000000000..1f617e5479cd
--- /dev/null
+++ b/app-admin/mktwpol/Manifest
@@ -0,0 +1,2 @@
+DIST mktwpol-0.2.4.tar.gz 53431 SHA256 b484f52f1b11834914e7c187f8a0778dad59bb90b5652005a565ed0ffb1c9d77 SHA512 b8fcb8c18e1aa44f0e1198e1f4f5a7a1cfc8705d169e6fccbc7c40f6bf87552be7ae35c03073fb7b64d859835843721a2639c8fbd0af4d067c2f472903fed124 WHIRLPOOL c2cd1b238fa237242057896e3fbc587ce5d6836cb9f44bb998ca6da229f868fd1eb00485747043f315756e16a2c36c0960b11df22fe6543e69e25c376bfe2a87
+DIST mktwpol-0.2.5.tar.gz 54627 SHA256 3d1a06fedd2ff7fc02180ea12bdda64f2d9b952bdeeef77408dcdc17fc4f57cb SHA512 2c9a6b6573b7922f63e992f107fb95251f35bacd38a7ceccffb438be257c2a577e0ed34bb21f063d263f31d7725360db7df5e0235331d3a465304447e35f2fab WHIRLPOOL a5a64326900686e9d7d3d2a1c2b0baed9dbfe2ec35cba020d17193d83ce958b0c7964b317268f71af428ab967309710bf232b4cb2aa23cc67b276e2b49e1ebf7
diff --git a/app-admin/mktwpol/metadata.xml b/app-admin/mktwpol/metadata.xml
new file mode 100644
index 000000000000..3bb560150e4f
--- /dev/null
+++ b/app-admin/mktwpol/metadata.xml
@@ -0,0 +1,42 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>nimiux@gentoo.org</email>
+ <name>Chema Alonso</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>c.cboldt@gmail.com</email>
+ <name>Chuck Seyboldt</name>
+ <description>Will reply to bug reports</description>
+ </maintainer>
+ <changelog>https://sourceforge.net/p/mktwpol/code/ci/master/tree/CHANGES</changelog>
+ <doc>https://sourceforge.net/p/mktwpol/code/ci/master/tree/README</doc>
+ <bugs-to>https://sourceforge.net/p/mktwpol/discussion/bugs/</bugs-to>
+ <remote-id type="sourceforge">mktwpol</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ mktwpol is a tool that aids system administrators in the
+ set-up and maintenance of tripwire (an Intrusion
+ Detection System). It contains a pair of bash scripts,
+ mktwpol.sh and twsetup.sh. mktwpol.sh generates a
+ tripwire policy file that is tailored to the packages
+ installed on any given sytem. twsetup.sh steps through
+ the initial set-up of tripwire, including the generating
+ of encryption keys and encrypting the files that are
+ necessary for tripwire to perform its function.
+ </longdescription>
+ <longdescription lang="es">
+ mktwpol es una herramienta que ayuda a los administradores
+ de sistemas en la configuración y el mantenimiento de
+ tripwire (un Sistema de Detección de Intrusos). Contiene
+ dos guiones bash: mktwpol.sh y twsetup.sh. mktwpol.sh
+ genera un fichero de directriz para tripwire ajustada
+ a los paquetes instalados en un sistema. twsetup.sh realiza
+ la configuración inicial de tripwire, incluyendo la
+ generación de las claves de cifrado y realiza el
+ cifrado de los ficheros necesitados por tripwire para
+ realizar su función.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-admin/mktwpol/mktwpol-0.2.4.ebuild b/app-admin/mktwpol/mktwpol-0.2.4.ebuild
new file mode 100644
index 000000000000..20eed1467ef0
--- /dev/null
+++ b/app-admin/mktwpol/mktwpol-0.2.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Bash scripts to install tripwire and generate tripwire policy files"
+HOMEPAGE="https://sourceforge.net/projects/mktwpol"
+SRC_URI="mirror://sourceforge/mktwpol/${P}.tar.gz"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="app-admin/tripwire"
+
+src_prepare() {
+ sed -i -e 's|/usr/local|/usr|' Makefile || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ elog
+ elog "Installation and setup of tripwire ..."
+ elog " - Run: \`twsetup.sh\`"
+ elog
+ elog "Maintenance of tripwire as packages are added and/or deleted ..."
+ elog " - Run: \`mktwpol.sh -u\` to update tripwire policy and database"
+ elog
+ elog "Mktwpol is packaged with multiple policy-rules-generating files."
+ elog "The default \"rules file\" is installed in /etc/tripwire"
+ elog "Alternatives are installed in /usr/share/doc/${P}"
+ elog "To use an alternative \"rules file\" ..."
+ elog "copy it to /etc/tripwire, uncompress it, and \`touch\` it ..."
+ elog
+ elog "\`cp /usr/share/doc/${P}/mktwpol*.rules.bz2 /etc/tripwire\`"
+ elog "\`bunzip2 /etc/tripwire/mktwpol*.rules.bz2\`"
+ elog
+ elog "mktwpol.sh uses the rules file with the most recent date."
+ elog "Use \`touch\` to choose between multiple rules files."
+ elog
+}
diff --git a/app-admin/mktwpol/mktwpol-0.2.5.ebuild b/app-admin/mktwpol/mktwpol-0.2.5.ebuild
new file mode 100644
index 000000000000..ab566371055f
--- /dev/null
+++ b/app-admin/mktwpol/mktwpol-0.2.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Bash scripts to install tripwire and generate tripwire policy files"
+HOMEPAGE="https://sourceforge.net/projects/mktwpol"
+SRC_URI="mirror://sourceforge/mktwpol/${P}.tar.gz"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="app-admin/tripwire"
+
+src_prepare() {
+ sed -i -e 's|/usr/local|/usr|' Makefile || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ elog
+ elog "Installation and setup of tripwire ..."
+ elog " - Run: \`twsetup.sh\`"
+ elog
+ elog "Maintenance of tripwire as packages are added and/or deleted ..."
+ elog " - Run: \`mktwpol.sh -u\` to update tripwire policy and database"
+ elog
+ elog "Mktwpol is packaged with multiple policy-rules-generating files."
+ elog "The default \"rules file\" is installed in /etc/tripwire"
+ elog "Alternatives are installed in /usr/share/doc/${P}"
+ elog "To use an alternative \"rules file\" ..."
+ elog "copy it to /etc/tripwire, uncompress it, and \`touch\` it ..."
+ elog
+ elog "\`cp /usr/share/doc/${P}/mktwpol*.rules.bz2 /etc/tripwire\`"
+ elog "\`bunzip2 /etc/tripwire/mktwpol*.rules.bz2\`"
+ elog
+ elog "mktwpol.sh uses the rules file with the most recent date."
+ elog "Use \`touch\` to choose between multiple rules files."
+ elog
+}