summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/needrestart')
-rw-r--r--app-admin/needrestart/Manifest2
-rw-r--r--app-admin/needrestart/needrestart-3.3.ebuild40
-rw-r--r--app-admin/needrestart/needrestart-3.5.ebuild42
-rw-r--r--app-admin/needrestart/needrestart-3.6.ebuild4
4 files changed, 2 insertions, 86 deletions
diff --git a/app-admin/needrestart/Manifest b/app-admin/needrestart/Manifest
index 9c6d3a63c444..3b9b3e406169 100644
--- a/app-admin/needrestart/Manifest
+++ b/app-admin/needrestart/Manifest
@@ -1,3 +1 @@
-DIST needrestart-3.3.tar.gz 59814 BLAKE2B bfba00dee7c0f225efcaaa80b301eb38d0ea82645f253c8bef9294102f9f4183433ed1b6efe71a9dc34c65f76364ff3fc2344e840b34f97361f3ddcd0dc9ab4b SHA512 ea2f3cbe228a6b879905bd3b3de8b5e0bb2362e8d3cd566817d2e7d519d54207ff5923eb8e49cbd8ffe8ed50729f4da04bf4d55268e806f49157860584058d50
-DIST needrestart-3.5.tar.gz 67824 BLAKE2B 73af940efa578b145d89cb0724f7103edd0fe869bfb211596109b67fd16a8ddce83060942687c3ca0e861d9d545022845b64d90bc44e39997e8943b1575dd5f1 SHA512 e082ab92497cce7b65da9c625ba0bc2332cc7863c5b7d99a04593c646256da0302519fb7c9fc9823ce0058affdf7eb6a4587a1874881eda8aa4d07032093eb0b
DIST needrestart-3.6.tar.gz 71159 BLAKE2B 76994ef0e77a4db0532dca2e17990097b2314f912fc3c32e67643eca7c44fff9611a42b49abd55f959a0e959d6ea69cfef36ad9008c86debfd125b64bdc673b5 SHA512 5c0f2f427c93e6f621fc1727f6abf42651e184e168b3f720708ac73b425bc7dfb94622c6cc2afad1161e3ffbfd36500eb99c375f2f5a525c9cd10d7142f1e365
diff --git a/app-admin/needrestart/needrestart-3.3.ebuild b/app-admin/needrestart/needrestart-3.3.ebuild
deleted file mode 100644
index 576521c08c4f..000000000000
--- a/app-admin/needrestart/needrestart-3.3.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/liske/${PN}.git"
- inherit git-r3
- SRC_URI=""
-else
- SRC_URI="https://github.com/liske/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 x86"
-fi
-
-DESCRIPTION="Restart daemons after library updates"
-HOMEPAGE="https://fiasko-nw.net/~thomas/tag/needrestart.html https://github.com/liske/needrestart"
-
-SLOT="0"
-LICENSE="GPL-2+"
-
-RDEPEND="
- >=sys-apps/sed-4.2.2
- dev-lang/perl:=
- dev-perl/libintl-perl
- dev-perl/Module-Find
- dev-perl/Module-ScanDeps
- dev-perl/Proc-ProcessTable
- dev-perl/Sort-Naturally
- dev-perl/TermReadKey
- sys-apps/init-system-helpers
-"
-DEPEND="${RDEPEND}
- sys-devel/gettext
-"
-
-src_install() {
- default
- doman man/*.1
- dodoc -r ex
-}
diff --git a/app-admin/needrestart/needrestart-3.5.ebuild b/app-admin/needrestart/needrestart-3.5.ebuild
deleted file mode 100644
index cf3fcc8ac735..000000000000
--- a/app-admin/needrestart/needrestart-3.5.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/liske/${PN}.git"
- inherit git-r3
- SRC_URI=""
-else
- SRC_URI="https://github.com/liske/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 x86"
-fi
-
-DESCRIPTION="Restart daemons after library updates"
-HOMEPAGE="https://fiasko-nw.net/~thomas/tag/needrestart.html https://github.com/liske/needrestart"
-
-SLOT="0"
-LICENSE="GPL-2+"
-
-RDEPEND="
- >=sys-apps/sed-4.2.2
- dev-lang/perl:=
- dev-perl/libintl-perl
- dev-perl/Module-Find
- dev-perl/Module-ScanDeps
- dev-perl/Proc-ProcessTable
- dev-perl/Sort-Naturally
- dev-perl/TermReadKey
- sys-apps/init-system-helpers
- amd64? ( sys-apps/iucode_tool )
- x86? ( sys-apps/iucode_tool )
-"
-DEPEND="${RDEPEND}
- sys-devel/gettext
-"
-
-src_install() {
- default
- doman man/*.1
- dodoc -r ex
-}
diff --git a/app-admin/needrestart/needrestart-3.6.ebuild b/app-admin/needrestart/needrestart-3.6.ebuild
index c773506fddc2..c6ba2e67cc91 100644
--- a/app-admin/needrestart/needrestart-3.6.ebuild
+++ b/app-admin/needrestart/needrestart-3.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,7 +9,7 @@ if [[ ${PV} == "9999" ]] ; then
SRC_URI=""
else
SRC_URI="https://github.com/liske/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ KEYWORDS="amd64 ~arm arm64 x86"
fi
DESCRIPTION="Restart daemons after library updates"