summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/puppet-lint/puppet-lint-2.0.0.ebuild')
-rw-r--r--app-admin/puppet-lint/puppet-lint-2.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-admin/puppet-lint/puppet-lint-2.0.0.ebuild b/app-admin/puppet-lint/puppet-lint-2.0.0.ebuild
new file mode 100644
index 000000000000..5c672ff19972
--- /dev/null
+++ b/app-admin/puppet-lint/puppet-lint-2.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit eutils ruby-fakegem
+
+DESCRIPTION="A linter for puppet DSL"
+HOMEPAGE="http://puppet-lint.com/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec-its:1
+ dev-ruby/rspec-collection_matchers:1 )"