summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/puppet/puppet-3.8.7-r1.ebuild')
-rw-r--r--app-admin/puppet/puppet-3.8.7-r1.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/app-admin/puppet/puppet-3.8.7-r1.ebuild b/app-admin/puppet/puppet-3.8.7-r1.ebuild
index abc9fe39e986..f7e608e5bbfa 100644
--- a/app-admin/puppet/puppet-3.8.7-r1.ebuild
+++ b/app-admin/puppet/puppet-3.8.7-r1.ebuild
@@ -176,12 +176,15 @@ pkg_postinst() {
elog
fi
- if [ "$(get_major_version $REPLACING_VERSIONS)" = "2" ]; then
- elog
- elog "If you're upgrading from 2.x then we strongly suggest you to read:"
- elog "http://docs.puppetlabs.com/guides/upgrading.html"
- elog
- fi
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if [ "$(get_major_version $v)" = "2" ]; then
+ elog
+ elog "If you're upgrading from 2.x then we strongly suggest you to read:"
+ elog "http://docs.puppetlabs.com/guides/upgrading.html"
+ elog
+ fi
+ done
use emacs && elisp-site-regen
use xemacs && xemacs-elisp-site-regen