summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/pwman3')
-rw-r--r--app-admin/pwman3/Manifest3
-rw-r--r--app-admin/pwman3/pwman3-0.11.1.ebuild31
-rw-r--r--app-admin/pwman3/pwman3-0.12.2.ebuild (renamed from app-admin/pwman3/pwman3-0.10.0-r1.ebuild)22
3 files changed, 16 insertions, 40 deletions
diff --git a/app-admin/pwman3/Manifest b/app-admin/pwman3/Manifest
index 47c45d71e338..0f77c15a2e52 100644
--- a/app-admin/pwman3/Manifest
+++ b/app-admin/pwman3/Manifest
@@ -1,2 +1 @@
-DIST pwman3-0.10.0.tar.gz 75726 BLAKE2B ba7331bd3d36ac23d9151a5ebd4a343e2d8c523ba8b324850139a9ba4af8404ddf23380b3eaef523251e8f4137c5c56b6ab509c3927690fc612962ff872ea820 SHA512 a6dc24b2e1405a91f35a9a9155dde5409e35ce733bacee8858930d82443c09b8017e2701bc8c45688483b6c40554e4d6266f6cd21dc6f205b13f96e7de4f57c2
-DIST pwman3-0.11.1.tar.gz 76992 BLAKE2B cd7289781436f0f8b941d587c61b2d8a5cad52f3d57d01106d73b3da5930de2bd2df15fe5a4bcfbdce5e5733b7328764d6e4e2d18cba8a575cadad8835218e75 SHA512 111713e23b64a7492b5e2735b0d0117a81759bd9f25a87327a2aa4a465fbbc8a0aa0fbfa86b84cbcd40eb1540d05cdbc6fb81982fe61953df91979e674ce5640
+DIST pwman3-0.12.2.tar.gz 76744 BLAKE2B 5223169a267f0c35bcb26499138c9b768c6e29c4ce39d4fb89c56eb72d24a9729159bed93af24e12f1e0e6c1569586772eb36954afd51afc7c97c9de898346e5 SHA512 587839e7d532ef3c53e2c429b086eb6bd59290ce43687034400f8e0772cc4e97c9296694ad83c5fa3fdde37b8d8fef5bc150e9f81fcb9fe8712ffafb4be8b400
diff --git a/app-admin/pwman3/pwman3-0.11.1.ebuild b/app-admin/pwman3/pwman3-0.11.1.ebuild
deleted file mode 100644
index 57f062d5fbe8..000000000000
--- a/app-admin/pwman3/pwman3-0.11.1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="sqlite"
-inherit distutils-r1 optfeature
-
-DESCRIPTION="A lightweight password-manager with multiple database backends"
-HOMEPAGE="https://pwman3.github.io/pwman3/"
-SRC_URI="https://github.com/pwman3/pwman3/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/cryptography-2.3[${PYTHON_USEDEP}]
- >=dev-python/colorama-0.3.0[${PYTHON_USEDEP}]
-"
-BDEPEND="test? ( dev-python/pexpect[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests setup.py
-
-pkg_postinst() {
- optfeature "Support for mongodb" dev-python/pymongo
- optfeature "Support for postgresql" dev-python/psycopg:2
- optfeature "Support for mysql" dev-python/pymysql
-}
diff --git a/app-admin/pwman3/pwman3-0.10.0-r1.ebuild b/app-admin/pwman3/pwman3-0.12.2.ebuild
index 2e7f722ba09a..671c2afbb0dc 100644
--- a/app-admin/pwman3/pwman3-0.10.0-r1.ebuild
+++ b/app-admin/pwman3/pwman3-0.12.2.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_8 )
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="sqlite"
-DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_USE_PEP517=setuptools
+
inherit distutils-r1 optfeature
DESCRIPTION="A lightweight password-manager with multiple database backends"
@@ -15,15 +16,22 @@ SRC_URI="https://github.com/pwman3/pwman3/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64"
+IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/cryptography-2.3[${PYTHON_USEDEP}]
- >=dev-python/colorama-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
"
-BDEPEND="test? ( dev-python/pexpect[${PYTHON_USEDEP}] )"
-distutils_enable_tests setup.py
+python_test() {
+ "${EPYTHON}" -m tests.test_pwman || die "Tests fail with ${EPYTHON}"
+}
pkg_postinst() {
optfeature "Support for mongodb" dev-python/pymongo