summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/rex/rex-9999.ebuild')
-rw-r--r--app-admin/rex/rex-9999.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/app-admin/rex/rex-9999.ebuild b/app-admin/rex/rex-9999.ebuild
index cad3166f1de0..1b5ca9f0db12 100644
--- a/app-admin/rex/rex-9999.ebuild
+++ b/app-admin/rex/rex-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} == 9999 ]]; then
GITHUB_USER=RexOps
@@ -21,7 +21,7 @@ fi
inherit bash-completion-r1 perl-module ${VCS_ECLASS}
DESCRIPTION="(R)?ex, the friendly automation framework"
-HOMEPAGE="https://metacpan.org/release/Rex https://www.rexify.org"
+HOMEPAGE="https://metacpan.org/dist/Rex https://www.rexify.org"
SLOT="0"
IUSE="minimal test"
@@ -48,6 +48,7 @@ RDEPEND="
dev-perl/Expect
dev-perl/IPC-Shareable
dev-perl/XML-LibXML
+ net-misc/rsync
)
virtual/perl-Carp
virtual/perl-Data-Dumper
@@ -81,6 +82,7 @@ RDEPEND="
dev-perl/libwww-perl
dev-perl/YAML
virtual/perl-version
+ virtual/perl-Term-ANSIColor
"
# NB: would add test? !minimal? Test-mysqld, but I can't get that to work
BDEPEND="
@@ -91,13 +93,18 @@ BDEPEND="
virtual/perl-Module-Metadata
test? (
!minimal? (
- dev-perl/File-LibMagic
+ || ( dev-perl/File-LibMagic sys-apps/file )
+ dev-vcs/git
)
virtual/perl-File-Temp
+ dev-perl/Sub-Override
dev-perl/Test-Deep
+ dev-perl/Test-Exception
dev-perl/Test-Output
dev-perl/Test-UseAllModules
+ dev-perl/Test-Warnings
virtual/perl-autodie
+ virtual/perl-Module-Load-Conditional
)
"