summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/showconsole/files')
-rw-r--r--app-admin/showconsole/files/1.07-no-TIOCGDEV.patch27
-rw-r--r--app-admin/showconsole/files/bootlogger.sh33
-rw-r--r--app-admin/showconsole/files/showconsole-1.08-build.patch13
-rw-r--r--app-admin/showconsole/files/showconsole-1.08-no-pthread-yield.patch17
-rw-r--r--app-admin/showconsole/files/showconsole-1.08-quiet.patch34
5 files changed, 124 insertions, 0 deletions
diff --git a/app-admin/showconsole/files/1.07-no-TIOCGDEV.patch b/app-admin/showconsole/files/1.07-no-TIOCGDEV.patch
new file mode 100644
index 000000000000..49a09cea2155
--- /dev/null
+++ b/app-admin/showconsole/files/1.07-no-TIOCGDEV.patch
@@ -0,0 +1,27 @@
+--- showconsole-1.07/libconsole.c.orig 2004-12-03 21:57:24.507411240 -0500
++++ showconsole-1.07/libconsole.c 2004-12-03 21:59:26.820816776 -0500
+@@ -1021,13 +1021,8 @@
+ char * name = NULL;
+ DIR * dev;
+
+-#ifdef TIOCGDEV
++#define TIOCGDEV _IOR('T',0x32, unsigned int)
+ if (ioctl (0, TIOCGDEV, &tty) < 0) {
+- if (errno == EINVAL && !getenv("NOTIOCGDEV"))
+- warn("Warning: the ioctl TIOCGDEV is not known by the kernel\n");
+-#else
+-# error The ioctl TIOCGDEV is not defined (SuSE TIOCGDEV patch is missed)
+-#endif
+ if (!(name = ttyname(0)) || !strcmp(name, "/dev/console"))
+ tty = fallback(pid, ppid);
+ else {
+@@ -1036,9 +1031,7 @@
+ name = lnk;
+ goto out;
+ }
+-#ifdef TIOCGDEV
+ }
+-#endif
+
+ if (!(dev = opendir("/dev")))
+ error("can not opendir(/dev): %s\n", STRERR);
diff --git a/app-admin/showconsole/files/bootlogger.sh b/app-admin/showconsole/files/bootlogger.sh
new file mode 100644
index 000000000000..bea8568a0de6
--- /dev/null
+++ b/app-admin/showconsole/files/bootlogger.sh
@@ -0,0 +1,33 @@
+# /lib/rcscripts/addons/bootlogger.sh: Handle logging of output at boot
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+if [[ -x /sbin/blogd ]] ; then
+
+bootlog() {
+ [[ ${RC_BOOTLOG} == "yes" ]] || return 0
+
+ local opt=$1
+ shift
+ case ${opt} in
+ start) blogd_start "$@";;
+ sync) blogd_sync "$@";;
+ quit) blogd_quit "$@";;
+ esac
+}
+
+blogd_start() {
+ /sbin/blogd -q
+}
+
+blogd_sync() {
+ echo > /var/log/boot.msg
+ killall -IO blogd
+}
+
+blogd_quit() {
+ killall -QUIT blogd
+}
+
+fi
diff --git a/app-admin/showconsole/files/showconsole-1.08-build.patch b/app-admin/showconsole/files/showconsole-1.08-build.patch
new file mode 100644
index 000000000000..520a1607430b
--- /dev/null
+++ b/app-admin/showconsole/files/showconsole-1.08-build.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/143768
+
+--- showconsole-1.08/Makefile
++++ showconsole-1.08/Makefile
+@@ -37,7 +37,7 @@
+ RM = rm -f
+ MKDIR = mkdir -p
+ RMDIR = rm -rf
+- INSTBINFLAGS = -s -m 0700
++ INSTBINFLAGS = -m 0700
+ INSTBIN = install $(INSTBINFLAGS)
+ INSTDOCFLAGS = -c -m 0444
+ INSTDOC = install $(INSTDOCFLAGS)
diff --git a/app-admin/showconsole/files/showconsole-1.08-no-pthread-yield.patch b/app-admin/showconsole/files/showconsole-1.08-no-pthread-yield.patch
new file mode 100644
index 000000000000..7592b5ef8e25
--- /dev/null
+++ b/app-admin/showconsole/files/showconsole-1.08-no-pthread-yield.patch
@@ -0,0 +1,17 @@
+http://sourceware.org/cgi-bin/cvsweb.cgi/~checkout~/linuxthreads/linuxthreads/FAQ.html?rev=1.2.2.1&content-type=text/html&cvsroot=glibc#E
+
+use sched_yield, not pthread_yield
+
+http://bugs.gentoo.org/119762
+
+--- libconsole.c
++++ libconsole.c
+@@ -439,7 +439,7 @@
+ ret = 0;
+ }
+ } else
+- pthread_yield();
++ sched_yield();
+
+ return ret;
+ }
diff --git a/app-admin/showconsole/files/showconsole-1.08-quiet.patch b/app-admin/showconsole/files/showconsole-1.08-quiet.patch
new file mode 100644
index 000000000000..d03996056a5e
--- /dev/null
+++ b/app-admin/showconsole/files/showconsole-1.08-quiet.patch
@@ -0,0 +1,34 @@
+--- blogd.c
++++ blogd.c
+@@ -183,6 +183,7 @@
+ {
+ int fd, flags;
+ int ptm, pts, cntrtty = 1;
++ int quiet = 0;
+ pid_t pid, ppid = getppid();
+ char ptsname[NAME_MAX+1];
+ struct termios t;
+@@ -193,7 +194,14 @@
+ myname = basename(*argv);
+
+ if (argc > 2)
+- error("Too many args; usage: %s [/dev/tty<X>]\n", myname);
++ error("Too many args; usage: %s [-q] [/dev/tty<X>]\n", myname);
++
++ if (argc > 1 && strcmp(argv[1], "-q") == 0) {
++ quiet = 1;
++ --argc;
++ if (argc > 2)
++ argv[1] = argv[2];
++ }
+
+ if (argc == 2)
+ tty = argv[1];
+@@ -282,6 +289,7 @@
+ close(pts);
+ close(ptm);
+ close(fd);
++ if (!quiet)
+ fprintf(stdout, "\rBoot logging started on %s(%s) at %.24s\n", tty, name, stt);
+ fflush(stdout);
+ exit(0);