summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/stow/stow-2.3.1.ebuild')
-rw-r--r--app-admin/stow/stow-2.3.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/stow/stow-2.3.1.ebuild b/app-admin/stow/stow-2.3.1.ebuild
new file mode 100644
index 000000000000..834867c86051
--- /dev/null
+++ b/app-admin/stow/stow-2.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit perl-functions
+
+DESCRIPTION="GNU Stow is a symlink farm manager"
+HOMEPAGE="https://www.gnu.org/software/stow/"
+SRC_URI="mirror://gnu/stow/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="test"
+
+DEPEND="dev-lang/perl
+ test? (
+ dev-perl/IO-stringy
+ virtual/perl-Test-Harness
+ dev-perl/Test-Output
+ )"
+RDEPEND="dev-lang/perl:="
+
+src_configure() {
+ perl_set_version
+ econf "--with-pmdir=${VENDOR_LIB}"
+}