summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/sud')
-rw-r--r--app-admin/sud/files/sud-1.3-use-system-queue.patch68
-rw-r--r--app-admin/sud/metadata.xml2
-rw-r--r--app-admin/sud/sud-1.3-r2.ebuild (renamed from app-admin/sud/sud-1.3-r1.ebuild)20
3 files changed, 83 insertions, 7 deletions
diff --git a/app-admin/sud/files/sud-1.3-use-system-queue.patch b/app-admin/sud/files/sud-1.3-use-system-queue.patch
new file mode 100644
index 000000000000..c36b359d76ef
--- /dev/null
+++ b/app-admin/sud/files/sud-1.3-use-system-queue.patch
@@ -0,0 +1,68 @@
+https://bugs.gentoo.org/713470
+
+--- a/sud/Makefile.am
++++ b/sud/Makefile.am
+@@ -1,7 +1,7 @@
+ AM_YFLAGS = -d
+
+ sbin_PROGRAMS = sud
+-sud_SOURCES = conf.c conf_parser.y conf_lexer.l interactive.c noninteractive.c control.c main.c popen.c request.c session.c service.c utility.c extern.h conf.h control.h queue.h session.h
++sud_SOURCES = conf.c conf_parser.y conf_lexer.l interactive.c noninteractive.c control.c main.c popen.c request.c session.c service.c utility.c extern.h conf.h control.h session.h
+ sud_CFLAGS = -Wall -DYY_NO_UNPUT
+
+ #INCLUDES = -I..
+--- a/sud/conf.h
++++ b/sud/conf.h
+@@ -31,7 +31,7 @@
+ #include <sys/types.h>
+ #include <grp.h>
+
+-#include "queue.h"
++#include <sys/queue.h>
+ /*
+ * XXX: have* variables are oversized, perhaps these could be implemented using
+ * for example gid_t negative values
+--- a/sud/conf_lexer.c
++++ b/sud/conf_lexer.c
+@@ -537,7 +537,7 @@ char *yytext;
+ #include "conf.h"
+ #include "conf_parser.h"
+ #include "extern.h"
+-#include "queue.h"
++#include <sys/queue.h>
+
+ extern int nline;
+
+--- a/sud/conf_lexer.l
++++ b/sud/conf_lexer.l
+@@ -40,7 +40,7 @@
+ #include "conf.h"
+ #include "conf_parser.h"
+ #include "extern.h"
+-#include "queue.h"
++#include <sys/queue.h>
+
+ extern int nline;
+
+--- a/sud/service.c
++++ b/sud/service.c
+@@ -47,7 +47,7 @@
+
+ #include "conf.h"
+ #include "extern.h"
+-#include "queue.h"
++#include <sys/queue.h>
+ #include "session.h"
+
+
+--- a/sud/session.h
++++ b/sud/session.h
+@@ -32,7 +32,7 @@
+
+ #include <unistd.h>
+
+-#include "queue.h"
++#include <sys/queue.h>
+
+
+ struct sctl {
diff --git a/app-admin/sud/metadata.xml b/app-admin/sud/metadata.xml
index 39516e080887..a1dd37415783 100644
--- a/app-admin/sud/metadata.xml
+++ b/app-admin/sud/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>lu_zero@gentoo.org</email>
diff --git a/app-admin/sud/sud-1.3-r1.ebuild b/app-admin/sud/sud-1.3-r2.ebuild
index 7c72435d9c4d..f70d17d498c8 100644
--- a/app-admin/sud/sud-1.3-r1.ebuild
+++ b/app-admin/sud/sud-1.3-r2.ebuild
@@ -1,23 +1,31 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools flag-o-matic
DESCRIPTION="A daemon to execute processes with special privileges in a nosuid environment"
-HOMEPAGE="http://s0ftpj.org/projects/sud/index.htm"
-SRC_URI="http://s0ftpj.org/projects/sud/${P}.tar.gz"
+HOMEPAGE="http://www.s0ftpj.org/projects/sud/index.htm"
+SRC_URI="http://www.s0ftpj.org/projects/sud/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-PATCHES=( "${FILESDIR}"/${PN}-1.3-fix-build-system.patch )
+DEPEND="elibc_musl? ( sys-libs/queue-standalone )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3-fix-build-system.patch
+ "${FILESDIR}"/${PN}-1.3-use-system-queue.patch
+)
src_prepare() {
default
+
+ # bug #713470
+ rm sud/queue.h || die
+
eautoreconf
}