summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/cdist/Manifest1
-rw-r--r--app-admin/cdist/cdist-4.4.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-admin/cdist/Manifest b/app-admin/cdist/Manifest
index 4e1162754e31..00dcb3ea48d7 100644
--- a/app-admin/cdist/Manifest
+++ b/app-admin/cdist/Manifest
@@ -1,2 +1,3 @@
DIST cdist-3.1.13.tar.gz 303245 SHA256 9363b25d3119ca6266a3066fcae145009e00253745bd81987d92ebcb9e10f987 SHA512 df6562dda7b4fcedcc8e651f33f5ce59a7d6c297a32f7685529865a4d965b9111f352ddd38a15ba28dc5cc53385a483ec87cc43b235ef9eee02512b7fabc6f41 WHIRLPOOL d0b7ad0955d6a16018a9dd1d452afd714e819a0427dc685e20745847658a0c0a3323dd1f5d03967547bb879e448f09ea84ba69a11fa00ea6dcd06ce3180ef6c5
DIST cdist-3.1.9.tar.gz 260817 SHA256 37eb340a83f52f035468b817d9f1218c5954ba2910fb7a800dfe04cf8abae85b SHA512 e2cc40a38961fa5cbb6f51fc5ea2f6a8a1f86cd5b42d85204f2f71e2aba8393d5041a63e756d7c5666cc30c9ab528a9e0e5bccaea8c5a9ed079453cc87d76d06 WHIRLPOOL 41f9d06401149e06969f3d799c7b812e6a992ade3892c6de9f0723bf2a697d45a6c4d1fc46805ee81c340d1f8cb5ffead32d45e7e5bb8b46cbf6aca8a53dd7fa
+DIST cdist-4.4.1.tar.gz 377850 SHA256 adf4c558667aaec010fa391524c0c5a9f07e89b658d51e515bc04baf79ac8bbc SHA512 ed955c48c708c5b97dc803d3b8ea8742581b7b0153c2494dad64cecbaca00bad414c624f77caa9d5cea44130adea3b5a547bbbf3db2d5546ea694f4c736bd3b4 WHIRLPOOL f7e8e17dec5f1fbc64aefbda99147709eb67e4c54c931e77841f0490ec3dad16e2a0d9892c75986e70325f23dc185cb02c6cd872e34f3cf76f36605ba3ff1bb3
diff --git a/app-admin/cdist/cdist-4.4.1.ebuild b/app-admin/cdist/cdist-4.4.1.ebuild
new file mode 100644
index 000000000000..02cea87efb5f
--- /dev/null
+++ b/app-admin/cdist/cdist-4.4.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A usable configuration management system"
+HOMEPAGE="http://www.nico.schottelius.org/software/cdist/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/dist/html/*.html docs/dist/html/man{1,7}/*.html )
+ distutils-r1_python_install_all
+
+ doman docs/dist/man/man1/*.1 docs/dist/man/man7/*.7
+}