summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/webapp-config/webapp-config-9999.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/app-admin/webapp-config/webapp-config-9999.ebuild b/app-admin/webapp-config/webapp-config-9999.ebuild
index 2d1d3c7ad8d0..a1b3ec25500f 100644
--- a/app-admin/webapp-config/webapp-config-9999.ebuild
+++ b/app-admin/webapp-config/webapp-config-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -6,7 +6,7 @@ EAPI="5"
PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
-inherit distutils-r1
+inherit distutils-r1 prefix
if [[ ${PV} = 9999* ]]
then
@@ -30,6 +30,11 @@ DEPEND="app-text/xmlto
sys-apps/gentoo-functions"
RDEPEND="portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ eprefixify WebappConfig/eprefix.py config/webapp-config
+}
+
python_compile_all() {
emake -C doc/
}
@@ -40,7 +45,7 @@ python_install() {
# distutils does not provide for specifying two different script install
# locations. Since we only install one script here the following should
# be ok
- distutils-r1_python_install --install-scripts="/usr/sbin"
+ distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
}
python_install_all() {