summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/vault/vault-0.1.2-r1.ebuild8
-rw-r--r--app-admin/vault/vault-0.1.2.ebuild8
-rw-r--r--app-admin/vault/vault-9999.ebuild8
3 files changed, 12 insertions, 12 deletions
diff --git a/app-admin/vault/vault-0.1.2-r1.ebuild b/app-admin/vault/vault-0.1.2-r1.ebuild
index 770c1bb3ae44..f2adc6d07eb0 100644
--- a/app-admin/vault/vault-0.1.2-r1.ebuild
+++ b/app-admin/vault/vault-0.1.2-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit fcaps systemd user
+inherit fcaps golang-build systemd user
KEYWORDS="~amd64"
DESCRIPTION="A tool for managing secrets"
@@ -13,9 +13,9 @@ GO_PN="github.com/hashicorp/${PN}"
LICENSE="MPL-2.0"
SLOT="0"
IUSE=""
+RESTRICT="test"
-DEPEND=">=dev-lang/go-1.4:=
- dev-go/go-oauth2:="
+DEPEND="dev-go/go-oauth2:="
RDEPEND=""
SRC_URI="https://${GO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
@@ -45,7 +45,7 @@ src_unpack() {
cp -sR "${EPREFIX}"/usr/lib/go "${GOROOT}" || die
rm -rf "${GOROOT}/src/${GO_PN}" || die
- export GOPATH=${WORKDIR}:${WORKDIR}/src/github.com/hashicorp/vault/Godeps/_workspace
+ export GOPATH=${WORKDIR}:${WORKDIR}/src/github.com/hashicorp/vault/Godeps/_workspace:$(get_golibdir_gopath)
while read -r -d '' x; do
rm -rf "${GOROOT}/src/${x}" "${GOROOT}/pkg/${KERNEL}_${ARCH}/${x}"{,.a} || die
diff --git a/app-admin/vault/vault-0.1.2.ebuild b/app-admin/vault/vault-0.1.2.ebuild
index fad7f2eaf09f..452afb6f7e1e 100644
--- a/app-admin/vault/vault-0.1.2.ebuild
+++ b/app-admin/vault/vault-0.1.2.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit fcaps systemd user
+inherit fcaps golang-build systemd user
KEYWORDS="~amd64"
DESCRIPTION="A tool for managing secrets"
@@ -13,9 +13,9 @@ GO_PN="github.com/hashicorp/${PN}"
LICENSE="MPL-2.0"
SLOT="0"
IUSE=""
+RESTRICT="test"
-DEPEND=">=dev-lang/go-1.4
- dev-go/go-oauth2"
+DEPEND="dev-go/go-oauth2"
RDEPEND=""
SRC_URI="https://${GO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
@@ -45,7 +45,7 @@ src_unpack() {
cp -sR "${EPREFIX}"/usr/lib/go "${GOROOT}" || die
rm -rf "${GOROOT}/src/${GO_PN}" || die
- export GOPATH=${WORKDIR}:${WORKDIR}/src/github.com/hashicorp/vault/Godeps/_workspace
+ export GOPATH=${WORKDIR}:${WORKDIR}/src/github.com/hashicorp/vault/Godeps/_workspace:$(get_golibdir_gopath)
while read -r -d '' x; do
rm -rf "${GOROOT}/src/${x}" "${GOROOT}/pkg/${KERNEL}_${ARCH}/${x}"{,.a} || die
diff --git a/app-admin/vault/vault-9999.ebuild b/app-admin/vault/vault-9999.ebuild
index f315b8c60689..41d51d37941f 100644
--- a/app-admin/vault/vault-9999.ebuild
+++ b/app-admin/vault/vault-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit fcaps git-r3 systemd user
+inherit fcaps git-r3 golang-build systemd user
KEYWORDS=""
DESCRIPTION="A tool for managing secrets"
@@ -14,9 +14,9 @@ EGIT_REPO_URI="git://${GO_PN}.git"
LICENSE="MPL-2.0"
SLOT="0"
IUSE=""
+RESTRICT="test"
-DEPEND=">=dev-lang/go-1.4:=
- dev-go/go-oauth2:="
+DEPEND="dev-go/go-oauth2:="
RDEPEND=""
SRC_URI=""
@@ -43,7 +43,7 @@ src_unpack() {
cp -sR "${EPREFIX}"/usr/lib/go "${GOROOT}" || die
rm -rf "${GOROOT}/src/${GO_PN}" || die
- export GOPATH=${WORKDIR}:${WORKDIR}/src/github.com/hashicorp/vault/Godeps/_workspace
+ export GOPATH=${WORKDIR}:${WORKDIR}/src/github.com/hashicorp/vault/Godeps/_workspace:$(get_golibdir_gopath)
while read -r -d '' x; do
rm -rf "${GOROOT}/src/${x}" "${GOROOT}/pkg/${KERNEL}_${ARCH}/${x}"{,.a} || die