summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-alternatives/lex/lex-0-r1.ebuild')
-rw-r--r--app-alternatives/lex/lex-0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-alternatives/lex/lex-0-r1.ebuild b/app-alternatives/lex/lex-0-r1.ebuild
new file mode 100644
index 000000000000..e01caeecd23f
--- /dev/null
+++ b/app-alternatives/lex/lex-0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ALTERNATIVES=(
+ "flex:>=sys-devel/flex-2.6.4-r5"
+ reflex:sys-devel/reflex
+)
+
+inherit app-alternatives
+
+DESCRIPTION="lex symlinks"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ !<sys-devel/flex-2.6.4-r5
+"
+
+src_install() {
+ local alt=$(get_alternative)
+
+ dosym "${alt}" /usr/bin/lex
+ newman - lex.1 <<<".so ${alt}.1"
+
+ newenvd - 90lex <<-EOF
+ LEX=${alt}
+ EOF
+}