summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/cabextract')
-rw-r--r--app-arch/cabextract/Manifest4
-rw-r--r--app-arch/cabextract/cabextract-1.11.ebuild (renamed from app-arch/cabextract/cabextract-1.9.1.ebuild)17
-rw-r--r--app-arch/cabextract/cabextract-1.8.ebuild39
-rw-r--r--app-arch/cabextract/cabextract-1.9-r2.ebuild72
-rw-r--r--app-arch/cabextract/cabextract-9999.ebuild17
-rw-r--r--app-arch/cabextract/files/cabextract-1.9-fix-bigendian.patch17
-rw-r--r--app-arch/cabextract/files/cabextract-1.9-remove-spurious-test_files.patch17
7 files changed, 19 insertions, 164 deletions
diff --git a/app-arch/cabextract/Manifest b/app-arch/cabextract/Manifest
index d833dc8f192e..ccd96f2e0180 100644
--- a/app-arch/cabextract/Manifest
+++ b/app-arch/cabextract/Manifest
@@ -1,3 +1 @@
-DIST cabextract-1.8.tar.gz 289256 BLAKE2B ba9fea0cd12859b0de97b13362eaf276066650eb7151e0115af7ed2586cfa7497f72be2f9287d3ccb5ce5256ec26ca69e729df5bb0a327bb9f32ded25391460c SHA512 f8d676d6b738b0b13ac1cac7716c2fb46db423ef30b05ee64f00fcb19596131fbd34341c8b417af3de04896e9b6a8abf0d5976ee4bf87d016806a71317246d7a
-DIST cabextract-1.9.1.tar.gz 469369 BLAKE2B 5bfc697b40cbf47b42ab7857804b703c9622d8dae1648aae1bb5c0ec7c7978bff01b7ca2526f1b6090f193d88c00e3f49ae111f348d03fec9f575bddbb4b4096 SHA512 c354a4b20a222b40813f01baf8311c9a76611da427f9f44e977a3fd09508e24a18b486e3eef889a9debdca459f1b0c28d5d25429ccd555d3a2e4ff92d91cec14
-DIST cabextract-1.9.tar.gz 466334 BLAKE2B 1a82bddca826ee35ed13e1c0b50deca3ae1b7e31d7f427f54b5d6cf9651a727b7cbf8049c1a4326237725e007baecb4356721489611bb5e015bd7460e2530758 SHA512 d144c1df9ed8e8c339bcadb3d1be2eb2576bb066e3f75a3480df0d5e81407a633554e4674b3bb43716c0cf33a0f2327e6f798cd6d7825bceefa0ad839fcc3f64
+DIST cabextract-1.11.tar.gz 489656 BLAKE2B c0360e63359c3c3db26d442a92be8ac3f05903015be0f8fc76e81b572e882807b881756d6541aa77e55e8c083cda3363f8d2f9a32a7ab35a0b79482a9c91ef47 SHA512 416bdc5a889c3986b2a5d6ecb8526a69f2d85c34f4856da43951271ff4f31013e4197c56ea5f6b05061b511b980d5a65cb34b9b859d3013c1dbcbb89d43114f9
diff --git a/app-arch/cabextract/cabextract-1.9.1.ebuild b/app-arch/cabextract/cabextract-1.11.ebuild
index 47ed62fb64f9..aa1c7c5dffd9 100644
--- a/app-arch/cabextract/cabextract-1.9.1.ebuild
+++ b/app-arch/cabextract/cabextract-1.11.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=8
-inherit autotools toolchain-funcs
+inherit toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/kyz/libmspack.git"
- inherit git-r3
+ inherit autotools git-r3
MY_P="${PN}-9999"
LIBMSPACK_DEPEND="~dev-libs/libmspack-9999:="
else
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
MY_PV="${PV/_alpha/alpha}"
MY_P="${PN}-${MY_PV}"
SRC_URI="https://www.cabextract.org.uk/${P}.tar.gz"
@@ -27,10 +27,11 @@ LICENSE="GPL-3"
SLOT="0"
IUSE="extras"
-DEPEND="${LIBMSPACK_DEPEND}
- virtual/pkgconfig"
+DEPEND="${LIBMSPACK_DEPEND}"
RDEPEND="${LIBMSPACK_DEPEND}
extras? ( dev-lang/perl )"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
src_prepare() {
if [[ ${PV} == "9999" ]] ; then
@@ -44,7 +45,7 @@ src_prepare() {
default
- eautoreconf
+ [[ ${PV} == "9999" ]] && eautoreconf
}
src_configure() {
diff --git a/app-arch/cabextract/cabextract-1.8.ebuild b/app-arch/cabextract/cabextract-1.8.ebuild
deleted file mode 100644
index acb8183e9aa5..000000000000
--- a/app-arch/cabextract/cabextract-1.8.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="Extracts files from Microsoft cabinet archive files"
-HOMEPAGE="https://www.cabextract.org.uk/"
-SRC_URI="https://www.cabextract.org.uk/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="extras"
-
-RDEPEND="extras? ( dev-lang/perl )"
-
-src_prepare() {
- default
- # the code attempts to set up a fnmatch replacement, but then fails to code
- # it properly leading to undefined references to rpl_fnmatch(). This may be
- # removed in the future if building still works by setting "yes" to "no".
- export ac_cv_func_fnmatch_works=yes
-}
-
-src_compile() {
- emake AR="$(tc-getAR)"
-}
-
-src_install() {
- local DOCS=( AUTHORS ChangeLog INSTALL NEWS README TODO doc/magic )
- default
- docinto html
- dodoc doc/wince_cab_format.html
- if use extras; then
- dobin src/{wince_info,wince_rename,cabinfo,cabsplit}
- fi
-}
diff --git a/app-arch/cabextract/cabextract-1.9-r2.ebuild b/app-arch/cabextract/cabextract-1.9-r2.ebuild
deleted file mode 100644
index e8fcac6043f4..000000000000
--- a/app-arch/cabextract/cabextract-1.9-r2.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit autotools toolchain-funcs
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/kyz/libmspack.git"
- inherit git-r3
- MY_P="${PN}-9999"
-
- LIBMSPACK_DEPEND="~dev-libs/libmspack-9999:="
-else
- KEYWORDS="~alpha amd64 arm hppa ~ia64 ~loong ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
- MY_PV="${PV/_alpha/alpha}"
- MY_P="${PN}-${MY_PV}"
- SRC_URI="https://www.cabextract.org.uk/${P}.tar.gz"
-
- LIBMSPACK_DEPEND=">=dev-libs/libmspack-0.8_alpha:="
-fi
-
-DESCRIPTION="Extracts files from Microsoft cabinet archive files"
-HOMEPAGE="https://www.cabextract.org.uk/"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="extras"
-
-DEPEND="${LIBMSPACK_DEPEND}
- virtual/pkgconfig"
-RDEPEND="${LIBMSPACK_DEPEND}
- extras? ( dev-lang/perl )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-fix-bigendian.patch
- "${FILESDIR}"/${P}-remove-spurious-test_files.patch
-)
-
-src_prepare() {
- if [[ ${PV} == "9999" ]] ; then
- # Re-create file layout from release tarball
- pushd "${WORKDIR}" &>/dev/null || die
- cp -aL "${S}"/${PN} "${WORKDIR}"/${PN}-source || die
- rm -r "${S}" || die
- mv "${WORKDIR}"/${PN}-source "${S}" || die
- popd &>/dev/null || die
- fi
-
- default
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- --with-external-libmspack=yes
-}
-
-src_compile() {
- emake AR="$(tc-getAR)"
-}
-
-src_install() {
- local DOCS=( AUTHORS ChangeLog NEWS README TODO doc/magic )
- default
- docinto html
- dodoc doc/wince_cab_format.html
- if use extras; then
- dobin src/{wince_info,wince_rename,cabinfo,cabsplit}
- fi
-}
diff --git a/app-arch/cabextract/cabextract-9999.ebuild b/app-arch/cabextract/cabextract-9999.ebuild
index d3b2ec55b336..256ec4427719 100644
--- a/app-arch/cabextract/cabextract-9999.ebuild
+++ b/app-arch/cabextract/cabextract-9999.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=8
-inherit autotools toolchain-funcs
+inherit toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/kyz/libmspack.git"
- inherit git-r3
+ inherit autotools git-r3
MY_P="${PN}-9999"
LIBMSPACK_DEPEND="~dev-libs/libmspack-9999:="
else
- KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
MY_PV="${PV/_alpha/alpha}"
MY_P="${PN}-${MY_PV}"
SRC_URI="https://www.cabextract.org.uk/${P}.tar.gz"
@@ -27,10 +27,11 @@ LICENSE="GPL-3"
SLOT="0"
IUSE="extras"
-DEPEND="${LIBMSPACK_DEPEND}
- virtual/pkgconfig"
+DEPEND="${LIBMSPACK_DEPEND}"
RDEPEND="${LIBMSPACK_DEPEND}
extras? ( dev-lang/perl )"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
src_prepare() {
if [[ ${PV} == "9999" ]] ; then
@@ -44,7 +45,7 @@ src_prepare() {
default
- eautoreconf
+ [[ ${PV} == "9999" ]] && eautoreconf
}
src_configure() {
diff --git a/app-arch/cabextract/files/cabextract-1.9-fix-bigendian.patch b/app-arch/cabextract/files/cabextract-1.9-fix-bigendian.patch
deleted file mode 100644
index 760dd9dbb013..000000000000
--- a/app-arch/cabextract/files/cabextract-1.9-fix-bigendian.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-https://github.com/kyz/libmspack/commit/c19e707936947b45cf05bc9aaee68517c6c2aca6
-
----
- configure.ac | 1 +
- 1 files changed, 1 insertions(+)
-
-diff --git a/configure.ac b/configure.ac
---- a/configure.ac
-+++ b/configure.ac
-@@ -30,6 +30,7 @@ AC_CHECK_HEADERS([inttypes.h])
- # Checks for typedefs, structures, and compiler characteristics.
- AC_C_CONST
- AC_C_INLINE
-+AC_C_BIGENDIAN
- AC_TYPE_MODE_T
- AC_TYPE_OFF_T
- AC_TYPE_SIZE_T
diff --git a/app-arch/cabextract/files/cabextract-1.9-remove-spurious-test_files.patch b/app-arch/cabextract/files/cabextract-1.9-remove-spurious-test_files.patch
deleted file mode 100644
index d80b8704834c..000000000000
--- a/app-arch/cabextract/files/cabextract-1.9-remove-spurious-test_files.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-https://github.com/kyz/libmspack/commit/2f78851e3927b05931574b380ca6dccaf91e3807
-
----
- test/bugs.test | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/test/bugs.test
-+++ b/test/bugs.test
-@@ -2,7 +2,7 @@
- # test that known crash bugs remain fixed
- . test/testcase
-
--$cabextract -t $test_files/bugs/*.cab
-+$cabextract -t bugs/*.cab
-
- # fail if exit code indicates a crash (SIGBUS, SIGSEGV, etc.)
- test $? -le 1